Support » Plugin: PublishPress Future: Automatically Unpublish WordPress Posts » Set expirator at Block editor will not expired

  • Resolved goodday6

    (@goodday6)


    GoodDay Support,

    I want try to ask why setting the Post Expirator inside the Block Editor, after the expire time it will not change to draft mode? But if we setting the post in quick edit with Post Expirator it will work. I also checked with Post Expirator Options> debug log.

    https://drive.google.com/file/d/1B3iYdiwQ_3BDC8_NPt3VQbwsNgoSOL5I/view?usp=sharing

    Using the Version 2.4.4 now, previous using the Version 2.5 got some issue. so downgrade first to Version 2.4.4 using quickedit method until your latest version and try.

    any idea for this ?

    • This topic was modified 8 months ago by goodday6.
Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Steve Burge

    (@stevejburge)

    Thanks for reporting that @goodday6

    I can confirm the error. We’ll get it fixed quickly in a new release: https://github.com/publishpress/PublishPress-Future/issues/136

    I just ran across this issue. I changed the Post Expirator Advanced Setting ≥ Block Editor Support from:
    Show Gutenberg style box
    to:
    Show Classic Editor style box.

    It’s a temporary fix until the next release. You can also set the expiration in the Quick Edit in the All Posts list view as another workaround.

    I’ve experienced this problem when setting the expiration time creating a new post. I need to exit the block editor back to the posts list. Then going back into the block editor and setting the expiration time does work. As above, setting expiration time via Quick Edit also works.

    I’ve noticed that there is no cron entry created when it doesn’t work.

    Hope that helps.

    Plugin Author Steve Burge

    (@stevejburge)

    @robanna @drdavidc Yes, “Show Classic Editor style box” is a good workaround for now.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Set expirator at Block editor will not expired’ is closed to new replies.