Support » Plugin: Advanced Excerpt » set exceprt length to coustomized -read more- line

  • Hi,
    thanks for the plugin.
    Is there a possibility to set the length of the excerpt not to a certain word count but instead to always show all of the text until the manually inserted -Read More- break?
    Best,
    Theresa

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author WPKube

    (@wpkube)

    You’re welcome.

    Go to WP admin > Settings > Excerpt, around the middle you’ll see “Only filter the_content() when there’s no break (more) tag in the post content)”. Try checking that box and save changes.

    Thread Starter esather12

    (@esather12)

    Thank you so much for your quick reply.
    Maybe I misunderstand some basic things here but whn I change these settings they only seem to be applied to the very first post which is shown on my blog and only to a single language, in my case that would be the “Die CLN Gene…” (German) Post on this site: https://wptest.genderwoche.de/
    Here the excerpt is really only truncated after the –MORE– line. In the English translation of the article as well as for all other articles it still seem to truncate the excerpt after a certain word count (ALL articles contain –MORE– Lines).
    Also: In case of truncation after the whole intro text (until the –MORE– line), no “Read more” Link appears. They only appear when the exceerpts are truncated after a certain word count.
    Am I missing something crucial?
    Thank you so much for this great support!
    Best,
    Theresa

    Thread Starter esather12

    (@esather12)

    Oh, I just realized that it does not seem to work on ANY Post in the intended way. The reason why the full text until the –MORE– Line appeared on the German “Die CLN Gene…” Article was that from a previous test I still had this very text copied into the “Excerpt” field in my wordpress editor. Once I deleted the text from there, it now shows again an excerpt which is truncated after a certain word count, instead of showing the full text above the –MORE– Line… 🙁

    Thread Starter esather12

    (@esather12)

    Just to add another observation that might be helpful also to others. I found a workaround with which it is possible to display all text that comes before the –MORE– line since ticking the “Only filter the_content() when there’s no break (more) tag in the post content)” did not work for me.

    If you just set the excerpt legnth to a very high number (I used 999), it will show all text that comes before the –MORE– line (but no more than that).

    That’s quite a good solution for me for now.

    • This reply was modified 2 months, 1 week ago by esather12.
    Plugin Author WPKube

    (@wpkube)

    Oh, I misunderstood what you needed, sorry. The option I mentioned makes the plugin’s excerpt filtering not apply to posts that have the more tag, it skips them since they shouldn’t be truncated.

    So the high excerpt length number is working out, correct?

    Thread Starter esather12

    (@esather12)

    Yes, it does. Thank you very much. With the help of your plugin the excerpts look really nice now (https://wptest.genderwoche.de/en/) and I can customize their length entirely through the placement of the –READ MORE– Line, which is exactly what I wanted. Without your plugin my html formatting would have been deleted. Thanks a lot!

    The one thing I would still wish for would be the multilanguage compatibility (https://wordpress.org/support/topic/read-more-link-name-compatible-with-multilanguage-site/), since now the Link Caption is “Read the rest” both on the English and German site. It’s a minor thing though.

    Many thanks and happy holidays!
    Best,
    Theresa

    Plugin Author WPKube

    (@wpkube)

    Hi @esather12

    You’re welcome, happy to hear that.

    The Polylang compatibility for the read more text will be fixed today or tomorrow.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.