Yoast SEO
Set canonical URL for home page? (2 posts)

  1. websupportguy
    Posted 2 years ago #

    I am using Yoast SEO plugin to set the rel canonical for all pages of my website as recommended, but I am finding that when my home page is "paged" due to it being too long, the canonical URL changes to "[URL]/page/2".

    How can I fix the canonical URL of the home page? Is there a setting somewhere to over-ride this?


  2. Erwin1974
    Posted 2 years ago #

    There does not appear to be a setting for this.

    Which is a shame, because having a canonical url like:
    <link rel="canonical" href="http://www.yourdomain.com/" /> on your home page when the url of your home page is: http://www.yourdomain.com/
    and it is set to be a static page is not very benificial in my opinion.

    However, the plugin does support Googles pagination coding, so Google should be able to understand you page using those.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Yoast SEO
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic