Support » Plugin: Yoast SEO » Set Canonical is http://?

  • Resolved dirkargyle

    (@dirkargyle)


    Hi can you help cannonical url is http:// even if in general settings both WordPress Address (URL) and siteurl is https

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Support Rumejan Barbarona

    (@onlyincebu)

    Did you make the appropriate redirects from the HTTP version to HTTPS? In order to migrate your domain from HTTP to HTTPS, you would need to configure your server to do the redirect from the old URL to the new URL. Your hosting company tech support should be able to help you in this regard.

    For more information on HTTP to HTTPS migrations, we recommend the following guides:
    https://yoast.com/dev-blog/move-website-https-ssl/
    https://kinsta.com/blog/http-to-https/

    Thread Starter dirkargyle

    (@dirkargyle)

    hello I use flexible cloudflare ssl and wordpress https

    the problem is that canonical in the code is still http://

    I already change the general settings as https

    my server is already redirecting it.. the problem is in the code

    <link rel=”canonical” href=”http://

    href points to http

    this is also true in sitemap.xml

    • This reply was modified 3 years, 3 months ago by dirkargyle.
    • This reply was modified 3 years, 3 months ago by dirkargyle.
    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    Can you please flush all the cache from the Cloudflare to check whether this resolves the issue? If the issue persists, can you please show us some example URLs where the issue remains occurring for you so that we can take a look at them?

    Plugin Support Jerlyn

    (@jerparx)

    Closed due to lack of activity.

    Thread Starter dirkargyle

    (@dirkargyle)

    hello sorry for late reply don’t mind it anymore maybe it is caused by other plugins I will try to look into it.

    • This reply was modified 3 years, 2 months ago by dirkargyle.
    • This reply was modified 3 years, 2 months ago by dirkargyle.
    • This reply was modified 3 years, 2 months ago by dirkargyle.
    Thread Starter dirkargyle

    (@dirkargyle)

    please look at the canonical address it is not https although I change the site and website url in wordpress general settings

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Set Canonical is http://?’ is closed to new replies.