WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Set callback to my URL; Twitter Widget Pro STILL not Authorizing

[Resolved] Set callback to my URL; Twitter Widget Pro STILL not Authorizing

Viewing 12 replies - 1 through 12 (of 12 total)
  • I just noticed the next message:
    https://dev.twitter.com/blog/planning-for-api-v1-retirement

    This might have something to do with it?

    Plugin Author Aaron D. Campbell

    @aaroncampbell

    GradingGirl: Once you have set up the Consumer key/secret, there’s another box on the settings page titled “Authenticated Twitter Accounts” (it’s the top box unless you’ve rearranged them). In that box is a button labelled “Authorize New Account”. If you click that you’ll be taken to Twitter to Authorize your newly created application for your Twitter account.

    Aaron, same problem here.

    Entered consumer key/secret, filled the callback field with a valid url to my own domain but clicking the ‘Authorize New Account‘ just refreshes the settings page, it does not redirect me to Twitter. I’ve tried it with and without a ‘signed in’ status with Twitter. The part ‘Authenticated Twitter Accounts’ stays empty.

    Any ideas?

    Me three. Exact same thing as michielvanerp and GradingGirl. There is no “Authenticated Twitter Accounts” in my settings page.

    Hey, not sure if related, but in settings (in dev.twitter.com), I changed application type to read only, callback URL to the homepage of my website, and checked “Allow this application to be used to Sign in with Twitter”.
    After a few minutes, I went back to my WP dashboard and my account was available for authentication “Authorize new account”. Then I did the “Sign in to twitter” from that link in WP dashboard and I’m back up.

    ebrumley – You rock!! Thank you. YOU solved my problem; thank you for clarifying where that Twitter settings is located (dev.twitter.com). Program-illiterate folk like me need every detail spelled out. 🙂

    Mr_Cre8ive

    @jeremyjeremyryanbiz

    Exact same problem here. Solution?

    Mr_Cre8ive

    @jeremyjeremyryanbiz

    I figured it out!! After receiving your “Access Token” and “Access Token Secret” from the dev.twitter website, you must then COPY and PASTE those codes back into the “Consumer Key” and “Consumer Secret” fields (respectively) on the Twitter Widget Pro settings page in WordPress. The same place that you originally posted the first set of codes. Then, click “Authorize”. Hope this helps… It worked for me.

    Hmm all this tips will still not work for me…

    This is not resolved. I can’t authorize; have tried all tips above.

    Any other ideas?

    Moderator Jan Dembowski

    @jdembowski

    It’s resolved because the plugin author or the original poster says it’s resolved.

    If you have this problem and trying ebrumley’s solution didn’t fix it for you maybe you want to try starting your own thread? There might be something different about your setup than GradingGirl’s.

    http://wordpress.org/support/plugin/twitter-widget-pro#postform

    I got this work by

    – setting to read only
    – making sure i added www. on my callback url
    – refreshed dev. to discover my consumer keys changed
    – added it (made sure I clicked update before authorize)

    and it worked.

    spent 30mins on that and a very random permutation fixed it. Sorry I wasn’t more scientific!

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Resolved] Set callback to my URL; Twitter Widget Pro STILL not Authorizing’ is closed to new replies.