WordPress.org

Ready to get started?Download WordPress

Forums

Dynamic Widgets
[resolved] Set All Options to 'No' Issue (4 posts)

  1. onetrev
    Member
    Posted 2 years ago #

    I get this error message below when I try to save the dynamic widget settings for any new widget I create and try to "Set All Options to 'No'".

    "Dynamic does not mean static hiding of a widget. Hint: Remove the widget from the sidebar."

    It's always worked before. I use this feature to make a widget show on only a few pages or say just one custom post type. I can go through every post, post type, and tags and set them to no, but that's what this link should do me.

    Any thoughts?

    http://wordpress.org/extend/plugins/dynamic-widgets/

  2. Qurl
    Member
    Plugin Author

    Posted 2 years ago #

    Please make sure you do tick the checkboxes for the desired pages. This warning only occurs when you put everything on "No" (i.e. the 'Set all to No' option) and then hit Save.

  3. onetrev
    Member
    Posted 2 years ago #

    Unfortunately, it happens even when I DO check off boxes for the desired before saving. The strange thing is I can hit save without any boxes checked on my local copy of the site and I don't get the error.

    The only thing I can think of is maybe this script to add classes to my widgets is interfering?

    http://ednailor.com/2011/01/24/adding-custom-css-classes-to-sidebar-widgets/

    That being said it hasn't caused issues before (5+ sites). But until/if it happens again I can't give you any more clues.

    Thanks!

  4. Qurl
    Member
    Plugin Author

    Posted 2 years ago #

    No, I don't think so. It might be in a certain module or another plugin is interfering. Please let me know when you find something.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.