Support » Plugin: UsersWP - Social Login » Sessions path not matching server

  • Resolved elliesatt

    (@zee300)


    I’m not at all a technical person so please excuse the possibly un-technical description.

    I currently run into a ‘critical error’ when trying to execute social login for my websites users. This seems to be due to a misconfiguration in sessions paths between the WordPress plugin (UsersWP, using https://hybridauth.github.io/) and my server (self-managed on Upcloud).

    This is what shows on the error log: https://imgur.com/dufuAYS

    A friend kindly offered to investigate the issue. Not sure how accurate this is but he seems to think that the sessions path within HybridAuth is defined incorrectly (hardcoded?) to /var/cpanel/php/sessions when it should be /var/lib/php/sessions:

    See screenshot of his error log: https://imgur.com/4w22rDK

    You can replicate the critical error by going to https://300hours.com/login and clicking on either social login option (Google or Twitter).

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support Patrik

    (@wpdev10)

    Hi,

    Can you check with your server team about why the session.save_path value is different for your site? Local value is /var/cpanel/php/sessions/ea-php74 and master value is /var/lib/php/sessions/ so it can be the reason as the code is trying to write on local path but its not available or writable.

    Regards,
    Patrik

    Thread Starter elliesatt

    (@zee300)

    My server admin is the one that highlighted that issue – my website is self-hosted (if that’s the right term) which means I don’t have a cpanel etc. Server admin seems to think that the local value (/var/cpanel/php/sessions/ea-php74) is set by the plugin, but I’m getting the sense that you’re saying that’s also set on the server side?

    Thread Starter elliesatt

    (@zee300)

    Got it – it was a rogue file changing paths. Thanks for the help!

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.