Support » Plugin: Forms: 3rd-Party Integration » Service drop down bars not opening to edit

  • I am hoping to link my Pardot form handler to a form I have on my website. I know that you can use the URL Pardot generates and replace that in your html but I am using a WYSIWYG editor so am having trouble finding the html to edit, even when I use the text editor the full URL still appears in the form.

    SO.

    I thought maybe this plug in would help. I loaded it and when I click on “add a new service” the bar appears but when I click it to drop down all the field options nothing happens. It kind of gives a jump but doesn’t extend down. Now I have 3 services I have set up which have no data and I cannot even open them to delete them. I tried to uninstall the plugin and add it back in but it shows up with these services saved. Any idea why?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author zaus

    (@zaus)

    To diagnose the problem, open your browser Dev Tools (usually F12, or right-click anywhere and choose “Inspect”) and choose the Console tab, then refresh the page and look for any red javascript errors. There might be a conflict with another plugin, and make sure you’re using the most recent version of mine.

    The info is saved to a wp setting, and it sounds like uninstalling isn’t deleting the setting. Could you try my “Forms: 3rd party migrate” plugin? You’ll get a Tools menu option to export the raw settings (I hope you speak json), but you should also be able to save an empty value to start fresh.

    If you’re still having trouble, send me some screenshots and I’ll see if I can figure it out.

    Hi Zaus – thanks for getting back to me so quickly. I know I’m not helpful but I certainly don’t speak json to be able to figure out the 3rd party migrate plugin although I did install it and it just seems like a few radio buttons, with the settings then looking a little more complicated. I didn’t see any red errors by inspecting the page – I did get a yellow error which I pasted below. Tried to paste a screenshot but it did not go through

    JQMIGRATE: Migrate is installed, version 1.4.1
    admin.php?page=forms-3rdparty-integration-config:261 Resource interpreted as Stylesheet but transferred with MIME type text/html: “http://www.acrometis.com/wp-admin/admin.php?page=forms-3rdparty-integration-config”.
    content.min.js:2 [Deprecation] Element.createShadowRoot is deprecated and will be removed in M80, around February 2020. Please use Element.attachShadow instead. See https://www.chromestatus.com/features/4507242028072960 and https://developers.google.com/web/updates/2019/07/web-components-time-to-upgrade for more details.
    (anonymous) @ content.min.js:2

    Well now I went into the 3rd party migrate plugin, checked both radio buttons as Forms 3rd Party, deleted the settings instances I didn’t want and just left what I thought was the core of the code (pasted below) to update and now I have made a “critical error” in the plugin. Tried deleting and reinstalling but I get the same thing. I have the original code saved and when I copied that back in and hit update it still doesn’t work.

    {
    “debug”: {
    “email”: “kelia.scott@acrometis.com”,
    “sender”: “info@acrometis.com”,
    “mode”: [
    “debug”
    ],
    “separator”: “, ”
    },
    }

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.