Support » Plugin: Maintenance Redirect » Server stops responding with maintenance mode active

  • guidoscenicapp

    (@guidoscenicapp)


    Hi Peter,

    Thanks for making this simple yet powerful plugin. Exactly what I was looking for. I had it working yesterday. Only logged in admins or users from specific IP could access. Other users got the maintenance message (message only). All good. Although I did notice that maintenance message took a while to load.

    Today however, no maintenance message is showing anymore. Seems the server is timing out when accessing with an IP that’s not in the unrestricted list. When accessing with unrestricted IP, load time is normal.

    Any thoughts?

    Cheers and thanks,
    Guido

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Peter Hardy-vanDoorn

    (@petervandoorn)

    Hi @guidoscenicapp

    Glad you’re finding it useful.

    I’ve just tried to access your site and saw the message immediately – no delay loading and certainly no timeout errors. I wonder if it’s just “one of those things” – you know how even the best shared hosting can be a bit unreliable every now and then.

    Or possibly your hosting uses some aggressive caching which could be causing the problem.

    It’s hard to say really, those are just 2 of the top things I’ve come across that can cause problems.

    Have you looked in your PHP logs? Are there any messages there that might give a clue?

    Cheers

    Peter

    Thread Starter guidoscenicapp

    (@guidoscenicapp)

    Hmmm.. could be cashing problem indeed. I just tried with another mobile browser (Chrome) while on 4G (not-unrestricted IP). When I typed in scenic.app there was a timeout, but when I typed https://scenic.app I immediately got the maintenance message. After that, all entries worked. I’ll just leave as is. Guess it won’t be a problem for ‘regular’ visitors.

    Regarding PHP, I do get two PHP Warnings in the log, related the the plugin. Not sure if they are related or if I can just ignore them? I’m on PHP8 if that makes any difference.

    [22-Jul-202116:04:34 UTC] PHP Warning: Undefined array key 1 in /var/www/html/scenic.app/public_html/wp-content/plugins/jf3-maintenance-mode/wpjf3_maintenance_redirect.php on line 225
    [22-Jul-2021 16:04:34 UTC] PHP Warning: Undefined array key 2 in /var/www/html/scenic.app/public_html/wp-content/plugins/jf3-maintenance-mode/wpjf3_maintenance_redirect.php on line 225

    Cheers,
    Guido

    Plugin Author Peter Hardy-vanDoorn

    (@petervandoorn)

    Hmm… I guess it could have something to do with your server’s http -> https redirection? I wouldn’t have thought that in itself would effect the plugin as it only kicks in once the server has sorted itself out and WordPress initialises.

    I’ve just read an article saying there’s major Internet outages today affecting all sorts of sites, including Amazon, so perhaps it’s just a coincidence if you weren’t experiencing any problems yesterday but are today?

    Thanks for the PHP warnings – yes, they might have something to do with PHP8. I haven’t honestly done any testing on 8 yet, so that’s something to add to the to-do list 🙂

    Cheers

    Peter

    Plugin Author Peter Hardy-vanDoorn

    (@petervandoorn)

    Hi @guidoscenicapp again!

    Just tested on PHP 8 and I can’t replicate those PHP warnings, so I’m wondering if it’s to do with your server caching? My guess is that the caching is not exposing the IP address, so there’s nothing to test against (which might also explain the slowness I suppose).

    If you do manage to get the caching turned off, I’d be grateful if you’d let me know if the warnings still appear.

    Cheers

    Peter

    Thread Starter guidoscenicapp

    (@guidoscenicapp)

    Hi Peter,

    I’n not sure if the server is caching at all. It’s a Linode server running apache2. I built it from scratch, but did not install any cashing solution. And, as far as I know, Linode doesn’t do anything for that either.

    I have a feeling it’s maybe related to local browser cache, maybe in combination with slow 3G/4G connection. Cleaned the cache and then it works.

    I’ll guess we’ll write this off as a ‘glitch’ for the moment.

    One other suggestion… would be great if we could add IPv6 addresses to the unrestricted list. When I tried to do that I get “IP address invalid”. No biggie…just for next big update maybe.

    Cheers and thanks for your fast help.
    Guido

    Thread Starter guidoscenicapp

    (@guidoscenicapp)

    I’ve also changed the http > https redirection now.
    It was done in the virtual host file through rewrite rules. Now I have changed that for a Redirect (still in virtual host file)

    Loading seems faster now. I’m not sure if this made the difference though.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.