Support » Plugin: WP Store Locator » Server responds 403 on markers directory.

  • Hi,

    I noticed a 403 error on the storelocator page, for the markers dir. Why is the script looking for the folder?

    At first I thought it is due to my server settings, but it seems this happens on other installation aswel as my local dev.

    Thought you should know

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Tijmen Smit

    (@tijmensmit)

    Where does the 403 error show up?

    Does it also happen without custom markers and all other plugins disabled?

    It happens for both default and custom markers, on pages with shortcode [wpsl].

    I noticed it in my debug console after updating wp-core and the wpsl plugin yesterday. The error didn’t show for earlier versions. I havent had the chance to check it without all other plugins disabled though.

    Plugin Author Tijmen Smit

    (@tijmensmit)

    I don’t see it in my console, so let me know if it’s still there with all other plugins disabled.

    Turns out removing the startMarker is causing the error:

    `add_filter( ‘wpsl_js_settings’, ‘custom_js_settings’ );

    function custom_js_settings( $settings ) {
    $settings[‘startMarker’] = ”;

    return $settings;
    }`

    Perhaps, whenever you got the time, it would be nice if a fix can be implemented

    Plugin Author Tijmen Smit

    (@tijmensmit)

    What kind of server are you testing it on? Apache? I still can’t replicate the issue.

    But you can instead of using that code, just hide it with CSS as well.

    
    #wpsl-gmap img[src*="red@2x"] {
        display: none !important;
    }
    

    Replace red with the color of the marker.

    • This reply was modified 2 years, 2 months ago by Tijmen Smit.

    I’m experiencing this on 3 seperate Apache servers.

    But oh wait, I’m expecting the problem to be in one of the javascripts. The error shows on client-side instead of server level. You would have to open your browsers debug panel to see it.

    I will hide it with CSS for now.

    Thanks 😉

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Server responds 403 on markers directory.’ is closed to new replies.