Support » Plugin: wpForo Forum » Server resources

  • Resolved grayson9

    (@grayson9)


    As much as I love your forum I still have a couple of questions that I can’t shake off.

    1. My forum just seems to hang sometimes when I click through posts to post. MY main pages on the website do not do this.
    It appears to be fast sometimes and then very slow at other times.
    I cant work it out.
    My website speed is about 1.18 on Pingdom but these pages are not.

    2. Frequently when clicking through from post to post I will receive a server internal error warning 500 from Google. I have talked with the server and they say all is ok and I should talk to the developer of the plugin (normal thing for a server to say lol)
    As I was writing this I clicked through and an error came as follows

    500 – Internal Server Error
    This is a temporary server error.
    Please try to reload the webpage later.
    If you are the webmaster of this site please log in to Cpanel and check the Error Logs. You will find the exact reason for this error there.

    Common reasons for this error are:

    Incorrect file/directory permissions: Above 755.
    In order files to be processed by the webserver, their permissions have to be equal or below 755. You can update file permissions with a FTP client or through cPanel’s File Manager.

    Incorrect Apache directives inside .htaccess file.
    Make sure you have not specified unsupported directives inside the local .htaccess file. Such include PHP settings and Apache module settings.

    Any advice on this, please.

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author gVectors Team

    (@gvectors-team)

    Hi @grayson9,

    1. My forum just seems to hang sometimes when I click through posts to post. MY main pages on the website do not do this.
    It appears to be fast sometimes and then very slow at other times.
    I cant work it out.

    We just checked and found your forum pages are cached by WP Rocket. In dozens of support topics we’ve already explained why you should not enable cache plugins on forum pages. In wpForo Community these questions are answered lots of times. Please, exclude forum page from your cache plugin. There should be an option to exclude your forum Base URL to stop caching it.

    Then navigate to Dashboard > Forums > Settings > Features admin page and make sure the built-in wpForo cache functions are enabled. Set these three options YES:

    • Enable Member Cache
    • Enable Object Cache
    • Enable Memory Cache

    2. Frequently when clicking through from post to post I will receive a server internal error warning 500 from Google. I have talked with the server and they say all is ok and I should talk to the developer of the plugin (normal thing for a server to say lol)
    As I was writing this I clicked through and an error came as follows

    500 – Internal Server Error
    This is a temporary server error.
    Please try to reload the webpage later.
    If you are the webmaster of this site please log in to Cpanel and check the Error Logs. You will find the exact reason for this error there.

    Common reasons for this error are:

    Incorrect file/directory permissions: Above 755.
    In order files to be processed by the webserver, their permissions have to be equal or below 755. You can update file permissions with a FTP client or through cPanel’s File Manager.

    I’m sure this doesn’t wpForo issue. Something is wrong configured on your server. The folder permission you’re mentioning is incomplete. It should indicate the exact directory, so we could understand whether it related to wpForo or not.

    In any case, to exclude all possible issues from wpForo side I recommend do these stpes:

    1. Using a FileZilla or cPanle > File Manager set these folders 755:
    /wp-content/
    /wp-content/uploads/
    – this /wp-content/uploads/wpforo/ and all folders in this directory

    2. Click on the “Mark all read” button in forum footer section, then decrease the forum/topic logging limit by putting this code in your current active theme functions.php file:

    function my_custom_wpforo_max_logged_topics( $num ){ return 50; }
    add_filter('wpforo_max_logged_topics', 'my_custom_wpforo_max_logged_topics', 12);
    
    function my_custom_wpforo_cookie_max_logged_topics( $num ){ return 50; }
    add_filter('wpforo_cookie_max_logged_topics', 'my_custom_wpforo_cookie_max_logged_topics', 12);

    Here is an instruction how to add those code:
    https://www.wpbeginner.com/plugins/how-to-easily-add-custom-code-in-wordpress-without-breaking-your-site/

    Thread Starter grayson9

    (@grayson9)

    I appreciate your support and I apologise for not checking the previous pages prior to posting.

    Thank you so much

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Server resources’ is closed to new replies.