Support » Plugin: WebP Converter for Media » server problem

  • Resolved peterstevens

    (@peterstevens)


    Server configuration error
    Requests to images are processed by your server bypassing Apache. When loading images, rules from the .htaccess file are not executed. Occasionally, this only applies to known file extensions: .jpg, .png, etc. and when e.g. .png2 extension is loaded, then the redirections from the .htaccess file work, because the server does not understand this format and does not treat it as image files. Check the redirects for .png file (for which the redirection does not work) and for .png2 file (for which the redirection works correctly).

    Change the server settings to stop ignoring the rules from the .htaccess file. Please contact your server administrator.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Mateusz Gbiorczyk

    (@mateuszgbiorczyk)

    Hi @peterstevens,

    Thanks for your message.

    What is the answer? “Please contact your server administrator.” You did it?

    Yes…. but so far they said it seemed to be a plugin issue…
    I will keep you posted
    Or are you aware of anything?

    Plugin Author Mateusz Gbiorczyk

    (@mateuszgbiorczyk)

    How do you think this is a plugin problem? The plugin checks various server configuration issues and displays appropriate error messages.

    You have everything in the message.

    You seem a bit annoyed… sorry, but I find your tone inappropriate for someone who makes a product that is supposed to be good…

    This is the answer I got from the support of my server:

    Hello,

    Thank you for contacting SiteGround’s Helpdesk.

    Please have in mind that on all of our Site Tools’ websites our NGINX Direct Delivery is turned on by default:

    https://www.siteground.com/blog/nginx-direct-delivery/

    This is a method to serve static content of your website using the try_files functionality of NGINX. It allows us to remove the static content from the server memory, but still find it and serve it super fast directly from the NGINX, skipping the communication with the Apache web server.

    Since the NGINX Direct Delivery is turned on on your website any custom Apache rules for your static resources (such as the site images) do not take effect as the resources are served directly from NGINX to your visitors and not from the server.

    You may turned off the NGINX Direct Delivery via the Site Tools – > Speed – > Cache but please do have in mind that our SG Optimizer plugin also provides WebP converter:

    https://www.siteground.com/blog/even-faster-wordpress-sites-with-our-sg-optimizer-plugin/

    Therefore, I strongly recommend you to use the WebP functionality on our SG Optimizer and not through third-party plugins as we can not guarantee that they are compatible with our hosting environment, especially for WebP generation.

    If you have further questions or if you experience any further problems, please do not hesitate to submit a new support request from our Helpdesk

    This will ensure that there are no miscommunications or misunderstandings by keeping the different issues you face separated from each other.

    Best Regards,

    Donetian Petkov
    Senior Technical Support

    So I suggest you change your tone and start dealing with the problem, to make sure your product is absolutely fantastic!

    Plugin Author Mateusz Gbiorczyk

    (@mateuszgbiorczyk)

    Sorry, I didn’t mean that. Maybe I’m a bit annoyed because I have more reports of this kind. There is just an error message pasted in the body of your post, nothing to say hello. So why do you expect a super nice approach from me? By reading other threads on the support about this error, you would find out that I am not able to help you. Because it’s not a problem with the plug, but with the server.

    People expect me to respond quickly and specifically, to be nice, and often they won’t even take their time. Just read the plugin’s FAQ or similar threads on the support forum. There are answers to 99% of the questions. Why ask the same questions again?

    I did as much as I could to help the users as much as possible. The plugin detects all possible errors on the server and informs the user about them. Everything is described in detail in the message. Getting help from hosting tech support is almost a miracle, even though they are paid a subscription.

    People expect me to change something in the plug and fix it. I can not, because the plugin’s logic is based on redirects from the .htaccess file, and if the server caches such redirects, there’s nothing I can do.

    And look, you asked support a second time and got a more accurate answer. And you know it’s a server-side problem after all. The error you see in the plugin tells you that static files are handled without Apache. Your hosting confirmed this and this cannot be turned off. So what am I supposed to do? I do not see any sense in writing to me on this matter.

    Out of the last 20 threads in the support forum, 5 are dealing with the same issue as yours. What it comes from? People don’t want to check the latest threads and find the answer to their question. This is what I wrote about in the thread pinned to the forum, in the plugin’s FAQ. But you have to be willing to read it.

    Please don’t be surprised at my annoyance, but people really don’t want to ask their hosting tech support, they just ask me. And a large part of them, even though they received an answer from me, do not write back.

    Thank you for your reply – and yes my post was just the problem, without saying hi… I apologise.

    Thanks for your time!

    Plugin Author Mateusz Gbiorczyk

    (@mateuszgbiorczyk)

    @peterstevens, not no greeting, but approach. You have an error with the problem description and a request to contact the administrator of your server. What should you do? Contact him and come back to me with a description of the error and a response from your hosting host.

    What you sent in the first message was nothing new. Or you could just read the last few threads in the forum and have a reply ready. It’s just about respecting my time.

    I consider the case closed with my last post. You complain about wasting your time… however you are still poking at this problem.. Just close the case and let it RIP.

    You are telling me to do what I already did. You obviously have not properly followed what I have written. Stop being a pain in the neck and find something worthwhile doing!

    Good heavens…Now you are wasting my time!

    !

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.