Support » Networking WordPress » Server Not Found after creating second blog site

  • Resolved hevghirl

    (@hevghirl)


    I managed to upgrade to 3.0 from a single user in 2.9.2.

    I wanted to use the multisite feature and followed the instructions for creating a network. First of all I added:

    define('WP_ALLOW_MULTISITE', true);

    Then I went to Tools>Network and followed the directions by creating blogs.dir folder in wp-content folder, then copied and pasted the information for config.php:

    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', true );
    $base = '/';
    define( 'DOMAIN_CURRENT_SITE', 'fheathermoore.com' );
    define( 'PATH_CURRENT_SITE', '/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );
    define( 'AUTH_SALT', .... );
    define( 'SECURE_AUTH_SALT', .... );
    define( 'LOGGED_IN_SALT', .... );
    define( 'NONCE_SALT', ... );

    The authentication key information is deliberately left out above.

    followed by .htaccess:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]

    It all appeared to worked perfectly, and I managed to create a new site. However, when I tried to go into the backend or visit the site, I get the error message:

    “Server not found
    Firefox can’t find the server at sanctuaryofheap.fheathermoore.com.”

    You can visit the subdomain I created at: http://www.sanctuaryofheap.fheathermoore.com.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    You have to enable wildcard subdomains, which is how the blogs get served.

    First, ask your webhost if they support them.

    Second, add a wildcard subdomain record in your DNS records at your webhost.

    Just go add a subdomain and put * in it.

    Thanks for replying. I literally just found the solution online 5 minutes ago! I went into my host CPanel and added the wildcard subdomain, and it appears to work perfectly now. I’ve published test posts and it’s all good!

    One thing I did note when I set up the multisite was that I had problems with missing post pages and comments. As follows:

    1. I deactivated the plugins
    2. Deleted the .htaccess file
    3. Reverted to default permalink structure.

    Everything appeared fine.

    4. I re-added .htaccess
    5. Updated to pretty permalinks

    Posts pages and comments were missing again.

    6. Deleted .htaccess
    7. Reverted to default permalink structure. (All working fine).
    8. Reactivated pretty permalinks

    Posts and comments were missing again.

    9. Reverted to default permalink structure.
    10.Deactivated the secondary blog since the problems started after activation.
    11.I updated the permalink structure to pretty permalinks

    Everything worked fine.

    12.I added the .htaccess (The .htaccess file is directly copied from the codec for creating a network).
    13.Reactivated the secondary blog.

    All posts and comments are now working fine, but I thought you should know in case other readers were having the same problem.

    I was having the same issue, and just added the wildcard subdomain.

    Now I’m getting a 403 Forbidden error when I go to my test site.

    Here’s the blog: http://jpsblog.org

    And this is the error: http://test.jpsblog.org

    Any ideas?

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    Your host / tech team needs to also have enabled wildcards in apache for your domain name. (In the vhost entry)

    Thanks, andrea_r. Apparently godaddy won’t make a server-side change for a single site.

    I’m thinking that this isn’t going to work unless I switch hosts. Awful.

    I had my domain and hosting through GoDaddy but I recently switched the hosting to Hostgator, and thankfully they have the subdomain feature, as well as added domains. The switchover process was simple and quick. I’m sure there are plenty of hosts who will offer the same service.

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    goDaddy usually tries to get you to get a dedicated IP for that site and have it the main one for that IP.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Server Not Found after creating second blog site’ is closed to new replies.