Support » Networking WordPress » Server Migration Lead to Blank Page

  • Resolved infmz



    I’ve had to migrate my WP Network from one server to another (both are internal and not hosted by external companies). After following what I believe are all the necessary steps (backing up, copying, search/replace in DB, changing wp-config.php) all I see when I browse to my new domain/server is a blank page.

    Just to describe the process in a bit more detail:

    • I installed LAMP on new server (CentOS)
    • Installed phpmyadmin
    • Backed up wordpress installation via ftp & tar
    • Backed up db
    • Updated domain in database via search&replace
    • Moved wordpress installation to new server via unix tar command
    • Uploaded db via phpmyadmin
    • Edited wp-config.php

    And now I see a blank page.

    Just to make matters worse, I now see a blank page on my existing server too, though this seems to have triggered later. I’ve gone through my unix command history and other than tarring files across from one server to another, I haven’t done anything that ‘touched’ the wordpress installation.

    I’ve tried the renaming plugins trick but to no success. Also, the back end on my new server doesn’t seem to work either and the error message displayed reads,

    ERROR: Unknown error in LDAP Authentication.
    ERROR: Cookies are blocked or not supported by your browser. You must enable cookies to use WordPress.

    Thanks in advance!

    P.S. I’ve searched a whole afternoon before posting this

    EDIT: Might be worth adding that I’m allowing ports access individually on the redhat firewall, so far only 80 (virtual host), 21, 22 are allowed.

Viewing 15 replies - 1 through 15 (of 34 total)
  • blank page – php error. Start checking logs, disabling plugins and make sure you moved the themes over too. 😉

    ten to one, wp is looking for something that is missing.



    Thanks Andrea,

    Somehow I thought [and hoped] you’d respond lol. I recovered my old site through a two-day old backup. Speaking of missing, I’ve noticed that my htaccess files weren’t tarred over. Now I always thought that tar does copy dot files? There seems to be crucial ldap files missing too, maybe if I copy them back in it’ll be ok.

    Per chance, do you think that because the newer server runs on PHP 5.2 that this is too old?

    I reached a point where I was thinking of rebuilding the installation and merely importing the db… I rather not have to resort to that.



    Correction: The .htaccess files did in fact copy over, so something else has got to be the problem

    Right, and what I suggested was nothing to do with htaccess. 🙂

    There seems to be crucial ldap files missing too, maybe if I copy them back in it’ll be ok.

    That might be it, yes.

    Also Start checking logs, disabling plugins and make sure you moved the themes over too.




    All themes have been moved over and I already disabled plugins (by renaming, forgot to state in first post). The crucial files are there now too.

    Despite this the problem persists. I tried updating to PHP 5.3 and well, it just got very ugly so I rolled back lol.

    Just to clarify, should I have backed up the database prior to copying the site installation or doesn’t it really matter?

    Thank you.

    EDIT: I’m looking at the apache logs and found this appear a lot:

    [Fri Feb 04 15:18:25 2011] [error] [client *my IP*] PHP Parse error: syntax error, unexpected T_STRING in /var/www/html/index.php on line 10

    So…… what’s in index.php?

    Time to follow the trail down the rabbit hole.



    Oh dear… The index file contains so much gibberish that my terminal can’t display it and has made my machine choke lol. When I type in a term it’s using some alien script. This is really strange! Creating a new one has given life to my blog… Thank you very much, I can’t believe I didn’t check that. I’m just confused as to how that could have happened?

    Still can’t get onto the backend though.

    It’s possible that the same thing happened to your wp-admin/index.php

    I would recommend updating your WordPress installation from a fresh package. Start by backing up everything that’s on your current server (but obviously don’t overwrite the backup you’ve already got). Then, follow the instructions listed in the Manual Upgrade part of the codex.

    I’m just confused as to how that could have happened?

    Dunno. Corrupted file? Something got misnamed or overwritten in transfer? gremlins?

    But hey, you fixed it.



    The wp-admin/index.php is intact and well. I can view the login page for wp-admin but can’t actually log in. I’m being told that cookies aren’t enabled when they are, and that it has something to do with ldap, but things seem ok? There was a mu-plugin I forgot to disable, maybe that’ll will do the trick.

    EDIT: Disabling the mu ldap plugin lead to more blank/white pages, both on the admin and front end.

    Also, it seems that permalinks are not working though the htaccess file is present. A manual upgrade it might just have to be. Any other suggestions at this point?


    Eh, well for permalinks I was going to suggest resaving them but if you can’t get into the admin that’s kind of a moot point.

    honestly, at this point I can’t say exactly what’s wrong. someone will have to go in and poke around. Will an upgrade fix it? Who knows? that would work only if you’re missing files.



    I’ve renamed the plugins dir again, this time I didn’t get a blank page. However, I still can’t log on but now I’m not seeing any error messages either.

    Very strange…



    Just to give a further update, I’ve also tried to upgrade manually but the problem persists… I’m somehow starting to think that it might be server config related?

    Moderator Ipstenu (Mika Epstein)


    Going with that theory (server, that is) … What version of PHP are you running?



    Version 5.2.10 – I did try to upgrade at one point but that failed. If it helps I’m using CentOS.


Viewing 15 replies - 1 through 15 (of 34 total)
  • The topic ‘Server Migration Lead to Blank Page’ is closed to new replies.