[resolved] Server Migration Lead to Blank Page (35 posts)

  1. infmz
    Posted 5 years ago #


    I've had to migrate my WP Network from one server to another (both are internal and not hosted by external companies). After following what I believe are all the necessary steps (backing up, copying, search/replace in DB, changing wp-config.php) all I see when I browse to my new domain/server is a blank page.

    Just to describe the process in a bit more detail:

    • I installed LAMP on new server (CentOS)
    • Installed phpmyadmin
    • Backed up wordpress installation via ftp & tar
    • Backed up db
    • Updated domain in database via search&replace
    • Moved wordpress installation to new server via unix tar command
    • Uploaded db via phpmyadmin
    • Edited wp-config.php

    And now I see a blank page.

    Just to make matters worse, I now see a blank page on my existing server too, though this seems to have triggered later. I've gone through my unix command history and other than tarring files across from one server to another, I haven't done anything that 'touched' the wordpress installation.

    I've tried the renaming plugins trick but to no success. Also, the back end on my new server doesn't seem to work either and the error message displayed reads,

    ERROR: Unknown error in LDAP Authentication.
    ERROR: Cookies are blocked or not supported by your browser. You must enable cookies to use WordPress.

    Thanks in advance!

    P.S. I've searched a whole afternoon before posting this

    EDIT: Might be worth adding that I'm allowing ports access individually on the redhat firewall, so far only 80 (virtual host), 21, 22 are allowed.

  2. blank page - php error. Start checking logs, disabling plugins and make sure you moved the themes over too. ;)

    ten to one, wp is looking for something that is missing.

  3. infmz
    Posted 5 years ago #

    Thanks Andrea,

    Somehow I thought [and hoped] you'd respond lol. I recovered my old site through a two-day old backup. Speaking of missing, I've noticed that my htaccess files weren't tarred over. Now I always thought that tar does copy dot files? There seems to be crucial ldap files missing too, maybe if I copy them back in it'll be ok.

    Per chance, do you think that because the newer server runs on PHP 5.2 that this is too old?

    I reached a point where I was thinking of rebuilding the installation and merely importing the db... I rather not have to resort to that.

  4. infmz
    Posted 5 years ago #

    Correction: The .htaccess files did in fact copy over, so something else has got to be the problem

  5. Right, and what I suggested was nothing to do with htaccess. :)

    There seems to be crucial ldap files missing too, maybe if I copy them back in it'll be ok.

    That might be it, yes.

    Also Start checking logs, disabling plugins and make sure you moved the themes over too.


  6. infmz
    Posted 5 years ago #

    All themes have been moved over and I already disabled plugins (by renaming, forgot to state in first post). The crucial files are there now too.

    Despite this the problem persists. I tried updating to PHP 5.3 and well, it just got very ugly so I rolled back lol.

    Just to clarify, should I have backed up the database prior to copying the site installation or doesn't it really matter?

    Thank you.

    EDIT: I'm looking at the apache logs and found this appear a lot:

    [Fri Feb 04 15:18:25 2011] [error] [client *my IP*] PHP Parse error: syntax error, unexpected T_STRING in /var/www/html/index.php on line 10

  7. So...... what's in index.php?

    Time to follow the trail down the rabbit hole.

  8. infmz
    Posted 5 years ago #

    Oh dear... The index file contains so much gibberish that my terminal can't display it and has made my machine choke lol. When I type in a term it's using some alien script. This is really strange! Creating a new one has given life to my blog... Thank you very much, I can't believe I didn't check that. I'm just confused as to how that could have happened?

    Still can't get onto the backend though.

  9. Curtiss Grymala
    Posted 5 years ago #

    It's possible that the same thing happened to your wp-admin/index.php

    I would recommend updating your WordPress installation from a fresh package. Start by backing up everything that's on your current server (but obviously don't overwrite the backup you've already got). Then, follow the instructions listed in the Manual Upgrade part of the codex.

  10. I'm just confused as to how that could have happened?

    Dunno. Corrupted file? Something got misnamed or overwritten in transfer? gremlins?

    But hey, you fixed it.

  11. infmz
    Posted 5 years ago #

    The wp-admin/index.php is intact and well. I can view the login page for wp-admin but can't actually log in. I'm being told that cookies aren't enabled when they are, and that it has something to do with ldap, but things seem ok? There was a mu-plugin I forgot to disable, maybe that'll will do the trick.

    EDIT: Disabling the mu ldap plugin lead to more blank/white pages, both on the admin and front end.

    Also, it seems that permalinks are not working though the htaccess file is present. A manual upgrade it might just have to be. Any other suggestions at this point?


  12. Eh, well for permalinks I was going to suggest resaving them but if you can't get into the admin that's kind of a moot point.

    honestly, at this point I can't say exactly what's wrong. someone will have to go in and poke around. Will an upgrade fix it? Who knows? that would work only if you're missing files.

  13. infmz
    Posted 5 years ago #

    I've renamed the plugins dir again, this time I didn't get a blank page. However, I still can't log on but now I'm not seeing any error messages either.

    Very strange...

  14. infmz
    Posted 5 years ago #

    Just to give a further update, I've also tried to upgrade manually but the problem persists... I'm somehow starting to think that it might be server config related?

  15. Going with that theory (server, that is) ... What version of PHP are you running?

  16. infmz
    Posted 5 years ago #

    Version 5.2.10 - I did try to upgrade at one point but that failed. If it helps I'm using CentOS.


  17. v 5.2.10 should work on CentOS (I used it on CentOS 4).

    A fresh install works until you upload the old database/content, is that right?

  18. infmz
    Posted 5 years ago #

    Well that's the thing... I've already dropped the server theory and am thinking about the database. I didn't run a fresh install on the CentOS (5.5) server, I merely used tar to shift my installation over to the new server.

    I'm now looking to recreate the site from scratch and see if that works, by installing wordpress from scratch and then piece-by-piece shifting my content over and uploading the DB.

    *Edited for lack of clarity*

  19. For grins and giggles, and since it'll take you 5 minutes, do a fresh WordPress install and see if THAT works.

  20. infmz
    Posted 5 years ago #

    Lol thanks for the suggestion. Will give it a try later as I'm about to travel now.

    I was concerned about a fresh install due to my plugin configurations etc and going through everything one by one. But I guess I have no choice and am wasting too much time on it now.

    Thanks again. Will update when I get the chance.

  21. Yeah, when everything's wrong, make sure the BASIC stuff will work at all :) THEN add on the layers.

  22. infmz
    Posted 5 years ago #


    It must be a db issue as a new installation word perfectly fine.. So far that is. At this point, are you able to recommend a good guide to drop my old files, themes, plugins and DB back in? Or should I straight copy everything back in and upload the DB?

    Well, I'll take an image of the server for now and try the latter in the meantime! Thanks!

  23. infmz
    Posted 5 years ago #

    Ok, I've realised that importing the db tables individually and reconfiguring is very long and doesn't always 'work'. Any other suggestions at this point?


  24. Have you foudn the error logs on the server?

  25. infmz
    Posted 5 years ago #

    I have, I checked them earlier. The only errors shown were one related to a favicon.ico, which can't be serious. But the time of this 'error' didn't reflect my later login attempts.

  26. I;d clear that one up anyway, just because enough traffic on that kind of hit can cause speed issues (when you're back up).

    Otherwise, you may be at the point you need to hire someone to dig you out.

  27. infmz
    Posted 5 years ago #

    Yeah, I will start paying to lot more attention to logs =)

    Well right now, I've kept an image of the current state of the blog. From there I've made a copy and reinstalled wordpress and am slowly copying my tables backover... It's quite a horrific task, but I gotta get something running by the end of the week.

    EDIT: I've just seen how much work I'd have to redo if I got about this way... Probably better avoiding it then!

  28. infmz
    Posted 5 years ago #

    I'm moving forward finally!!!

    I've managed to login on the newer installation. But my ldap and permalinks are still not working.

    Basically, it seems there were some problems in my DB as I backed it up a second time and done a search replace again. Though I done a replace all, in some cases it was wrong, I'm guessing it was my doing.

    Anyway, on the new install I made sure the DB had no such discrepancies and I'm in. Though I think there's more problems with the first.

    Now for resolving my ldap authentication and permalinks. I have a htaccess file and permalinks are set, but it's still not resolving...

  29. infmz
    Posted 5 years ago #

    Since I can't edit my last post now and I noticed the meaningless sentances... By wrong I meant that the URL was a tad bit wrong, some instances had my new url mixed with the old!?

    By problems with the first, I meant the first installation (the one that loops).

    Regarding permalinks, in the setup the desired method is set, htaccess looks correct, I added RewriteEngine On and RewriteOptions Inherit to my vhost, and allowed AllowOverRide to All...

    As for ldap, open ldap is installed as is the php-ldap package. The settings are exactly as with the last but its still not authenticating.

    EDIT: Resaving the pages/posts hasn't worked for me...

  30. infmz
    Posted 5 years ago #

    Here's the error log,

    [Wed Feb 09 09:50:48 2011] [error] [client] File does not exist: /var/www/html/forms, referer: {My URL}

    So apache isn't doing its job properly I assume.

    P.S. Pardon the quad-posts, can't edit my previous. =)

Topic Closed

This topic has been closed to new replies.

About this Topic