Support » Plugin: TablePress » Server Error when activating TablePress after migration from WP-Table-Reloaded

  • I am running WP 3.5.1, MySQL 5.5.29, PHP 5.2.17 on Linux.
    After migrating from WP-Table-Reloaded 1.9.4, I attempted to activate TablePress 0.9 RC and received the following error message in Chrome 24.0.1312.52 :

    Server error
    The website encountered an error while retrieving It may be down for maintenance or configured incorrectly.
    Here are some suggestions:
    Reload this webpage later.
    HTTP Error 500 (Internal Server Error): An unexpected condition was encountered while the server was attempting to fulfill the request.

    Then, when attempting to navigate to the Plugins page, so I can begin deactivating, potentially conflicting plugins, I get the same error message, except the URL reference is the plugins.php page:

    Server error
    The website encountered an error while retrieving It may be down for maintenance or configured incorrectly.

    I also get the same error message when attempting to, via the backend admin area, list the Pages, Posts and other constructs.

    I tried replacing all the wp-admin folder contents with a fresh wp-admin folder from a WP 3.5.1 download, but that did not fix the problem (still get the aove error message).

    I also tried dumping all server-side and browser-side cached content and refreshing pages, but that did not fix the problem (still get the above error message).

    To remove the above “Server error”s, I logged into my host cPanel and simply renamed the tablepress plugin folder (simulating deletion of the folder, without deleting the folder). All backend admin functions are now restored and WP-Table-Reloaded continued to function just fine. So, now, I am wary of upgrading to TablePress 0.9 RC, since it caused this Server error issue to occur.

Viewing 6 replies - 1 through 6 (of 6 total)
  • typo, I should have typed plugins.php, not pllugins.php in the above post link reference.

    Plugin Author TobiasBg


    Hi Bob,

    thanks for this report, and sorry for the trouble.

    Unfortunately, I have no idea why this happens, or what causes this. Also, you are the first to report this issue.

    Now, as there’s a server issue raised, this means that there should be an error message in the server’s error log. Can you please try to get that error message from the server error log? You might have to contact your webhost company, if you don’t have direct access to these logs.


    Hi Tobias,

    I have been using TablePress for sometime now and its truly a great plugin until recently I updated its version via the WP Admin Panel and then I started experiencing this very same problem as Bobs.

    I kept getting the same “505 Internal Server Error” prompt and now I am in urgent need again of your help for the site will be relaunched soon and I need to get the TablePress plugin working for I have over four different TablePress tables on our site that will actually be showcased as one of the sites main features.

    My client truly loves your plugin and was really saddened that we are now running into this problem with only days away from our launch.

    Hope you can help us out the soonest time possible. We desperately need your help on this one.

    Will wait for your feedback.

    Thanks again for your time.

    Plugin Author TobiasBg



    thanks for your post, and sorry for the trouble.

    Can you explain in more detail where exactly you are getting this error, and what actions you performed to get there?

    If you want, I can take a direct look at this on your site. For that, please send me an email (my address is in the main plugin file “tablepress.php”), with the credentials to a temporary admin account.


    Here is an update to my post originated 7 months ago:

    Yesterday, I successfully upgraded from WP-Table Reloaded to TablePress version 1.1.1, and I no longer get the Server Error. Not sure why. I am using the same server/hosting provider now, as back then.

    To make the TablePress CSS compatible with styles.css in Canvas theme version 5.1.3, WooThemes Framework 5.5.3, WordPress 3.6.1, I included this in the TablePress Custom CSS box (Plugin Options):

    .tablepress {
    	border-collapse: separate;

    Without that, my TablePress tables would not show the white border around the tables, as now seen in the following page. Under WP-Table-Reloaded, I did not have to include the above custom CSS fix – the border rendered just fine without this fix.


    Thanks, again, for an awesome TablePress plugin.

    Plugin Author TobiasBg



    thanks for this update! Good to hear that the migration went well!

    Yes, under WP-Table Reloaded, this CSS was not necessary, as it was part of the default CSS. TablePress has a new/fresher default styling, and that doesn’t use that CSS. But adding it like you did is perfectly fine.

    Best wishes,

    P.S.: In case you haven’t, please rate TablePress here in the plugin directory. Thanks!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Server Error when activating TablePress after migration from WP-Table-Reloaded’ is closed to new replies.