Support » Plugin: W3 Total Cache » Server Error Message — Unable To Activate W3 Total Cache

  • Resolved WordWeaver777


    Hello. Over the past several weeks I have made multiple attempts to install and use W3 Total Cache, but I keep running into the same error message.

    My environment: I am running WordPress 3.2.1. I have direct access to the machine which runs my web server. I use MAMP Pro 2.0 on a 27″ 2.8 GHz Quad Core i7 iMac running Mac OS X Lion. MAMP Pro is an Apache-mySQL-PHP package. It uses the most recent version of each software.

    Whether I manually install the W3 Total Cache plug-in in my WordPress plug-ins folder by dragging and dropping, or use the “upload” link, or do an automatic download and install from the WordPress plug-ins site, the result is still the same.

    In each case, WordPress reports that the plug-in has been installed successfully. However, the minute that I click on the “activate” link, my server throws me the following error message:

    The website encountered an error while retrieving It may be down for maintenance or configured incorrectly.

    I have seen this same error message mentioned in dozens of other messages here on the WordPress support forum, and folks attribute it to all kinds of reasons, but I didn’t find any which associate it with W3 Total Cache.

    Currently, I have the following plug-ins installed in my WP plug-ins folder:


    Even if I deactivate all of the above, and try to install and activate W3 Total Cache, the same error message still occurs.

    As per the installation instructions, I have also set the permissions on “wp-content” and ” wp-content/uploads” to 777 using the Terminal, but that hasn’t helped. I am assuming that this is because the problem isn’t with the installation itself, but with what occurs after that when I hit the “activate” link.

    Once this error message appears on my screen, while I can still access my blog, and view entries on it, I cannot go to the admin panel/dashboard.

    The only way to return things to normal is by manually removing every file and folder that was created by the W3 Total Cache installation.

    I don’t know if this will be of any help to the developer of W3 Total Cache, but following instructions I found in another post elsewhere, I opened the “wp-config.php” file and add the following in order to enable debugging:

    define(‘WP_DEBUG’, true);
    error_reporting( E_ALL | E_STRICT );
    ini_set(‘display_errors’, 1);

    Once I enable debugging, I am presented with the following on-screen messages. Do any of them offer any hints regarding why W3 Total Cache is throwing me this error?

    Deprecated: Function set_magic_quotes_runtime() is deprecated in /server-path-here/Blog/wp-settings.php on line 32

    Notice: add_option was called with an argument that is deprecated since version 2.3 with no alternative available. in /server-path-here/Blog/wp-includes/functions.php on line 3468

    Notice: Undefined index: sml_csv in /server-path-here/Blog/wp-content/plugins/seo-smart-links-personal/seo-smart-links-personal.php on line 1651

    Notice: Undefined index: sml_options in /server-path-here/Blog/wp-content/plugins/seo-smart-links-personal/seo-smart-links-personal.php on line 1665

    Notice: load_plugin_textdomain was called with an argument that is deprecated since version 2.7 with no alternative available. in /server-path-here/Blog/wp-includes/functions.php on line 3468

    Notice: register_sidebar_widget is deprecated since version 2.8! Use wp_register_sidebar_widget() instead. in /server-path-here/Blog/wp-includes/functions.php on line 3382

    Notice: load_plugin_textdomain was called with an argument that is deprecated since version 2.7 with no alternative available. in /server-path-here/Blog/wp-includes/functions.php on line 3468

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 122880 bytes) in /server-path-here/Blog/wp-admin/menu.php on line 88

    I would really like to get W3 Total Cache working in order to speed up my WordPress installation, so any help from the W3 Total Cache developer, or from anyone else here, would be greatly appreciated.

    Thanks so much!

Viewing 7 replies - 1 through 7 (of 7 total)
  • hi Wordweaver777

    The most concerning thing in that list is the Fatal Error at the end, which shows that you’ve run out of Memory. The number 33554432 actually refers to 32M of memory.
    So you’re WP installation is saying 32M is not enough.

    So try increasing it by adding this to your WP-config file, at the top after the <?php

    define(‘WP_MEMORY_LIMIT’, ’64M’);

    Hope this helps,

    Rob G

    Hello Granville. Thanks for your belated response, but I have given up on trying to use both W3 Total Cache and WP Super Cache. They were both giving me too many problems, and I just don’t have the time to understand it, or figure it all out. My server was just having too much down time while I tried to figure out these things, and the amount of down time was of more concern to me, so both plug-ins are history for now.

    Plugin Author Frederick Townes


    I’m really interested to know what else went wrong for you.

    Sorry Frederick, but it has been months now, and I honestly don’t remember. As I said in my previous post, I am done trying to use both plug-ins, as I was just having too much down time. I would just rather do without the plug-ins.

    Plugin Author Frederick Townes


    Ok, if you want me to do the installation for you please send me an email.

    I had exactly the same problem on my Mac using WordPress with MAMP. After activating the W3 Total Cache plugin I was not able to reach wp-admin anymore because of a 500 Internal Server Error.

    Increasing the memory limit from 32 to 64 MB by adding define('WP_MEMORY_LIMIT', '64M'); at the top of wp-config.php has helped!

    Thanks granville!

    Hello Granville and Frederick.

    I am not certain if increasing WP’s memory is what did the trick, or if the WordPress developers did something over the past four months in WP itself that fixed the problem, or if maybe the developer of MAMP PRO did something to his bundle which fixed things; but whatever the case may be, I have finally been able to successfully install W3 Total Cache.

    I did a manual local install — unzip and drag the folder — and just had to change permissions a few times on the “wp-content” folder, as well as on my blog’s “.htaccess” file.

    Other than that, that is basically all I did.

    Because I was worried about running into serious, time-consuming downtime like last time, I have left all settings at their default configurations, and I am not currently using a CDN. I was temporarily using “CloudFlare” some time ago, but I didn’t like how it operates, and I am not even sure if it is a full-fledged CDN. I think I read somewhere that it really isn’t.

    Anyway, thanks Granville for the advice, in case that is what fixed it; and thanks Frederick for offering to do the install.

    Frederick, if you have time to stop by my blog, just to let me know if things seem speedier or not, I’d appreciate it. I really can’t tell from my end, but maybe someone from the outside can.

    I can’t remember if I am allowd to post URL’s here, so just do a web search for Endtime Prophecy Net Blog.


Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Server Error Message — Unable To Activate W3 Total Cache’ is closed to new replies.