Support » Plugin: Shareaholic | share buttons, related posts, social analytics & more » Server error and high load whenever updating Shareaholic

  • Zee

    (@laserjobs)


    Whenever updating I first get the out of memory error twice
    E_ERROR: Allowed memory size of 268435456 bytes exhausted (tried to allocate 20480 bytes)

    Stack trace
    /public_html/wp-includes/post.php (5797)
    /public_html/wp-includes/post.php (5780)
    /public_html/wp-includes/class-wp-query.php (3018)
    /public_html/wp-includes/class-wp-query.php (3248)
    /public_html/wp-includes/class-wp-query.php (3357)
    /public_html/wp-content/plugins/shareaholic/public.php (611)
    /public_html/wp-includes/class-wp-hook.php (298)
    /public_html/wp-includes/class-wp-hook.php (323)
    /public_html/wp-includes/plugin.php (453)
    /public_html/wp-admin/admin-ajax.php (101)

    Second my server load goes through the roof for about an hour as php-fpm7.1 creates multiple instances.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Shareaholic

    (@shareaholic)

    Hi @laserjobs who is your host and are you on a shared plan?

    Zee

    (@laserjobs)

    I am on a VPS at vultr with the following stack:
    NGINX
    Apache
    PHP-FPM
    Varnish
    MySQL 5.6
    PHP 7.1

    MEMORY LIMIT 256MB

    • This reply was modified 1 month ago by  Zee.
    Plugin Author Shareaholic

    (@shareaholic)

    Do you have any caching plugins installed?

    Zee

    (@laserjobs)

    Yes W3 Total Cache: Page Caching only
    Autoptimize: CSS, JS and html minification

    Plugin Author Shareaholic

    (@shareaholic)

    If you flush W3 Total Cache, does the same error occur? The reason I ask is that on plugin upgrade, Shareaholic automatically triggers a cache flush. Maybe W3 Total Cache settings can be tweaked?

    Zee

    (@laserjobs)

    Same error occurs with or without caching. The error is fleeting and just shows up twice without any ill effect on the site. The larger issue is the server load for approximately 1 to 1 1/2 hours after an update. Here are some screen shots
    https://imgur.com/a/B45wC

    Plugin Author Shareaholic

    (@shareaholic)

    To clarify,

    1) did you turn off W3 Total Cache completely and updated Shareaholic again — and you saw the same spike?

    2) if you flush W3 Total Cache, no spike?

    Once cache is flushed, it will take some time for it to be built up again, which may explain the increased load for 1-2 hours.

    Load will also increase if there is memory swapping occurring. Looks like you’re already running at over 100% memory utilization (before upgrading)? That would also probably cause an out of memory error.

    You could tune your settings in such a way that they take up less memory ex. Varnish or memcached so that you’re consistently below 100% usage.

    Zee

    (@laserjobs)

    1. No, I have not disabled W3 Total Cache before updating (will try that next time)
    2. No spike flushing W3 Total Cache

    I was thinking the same thing about cache being rebuilt but that seems to not be the case. Does Shareaholic reindex all posts after an update?

    The memory usage normally sits around 45-60% of 1GB of RAM so I am thinking it has more to do with a hitting the memory limit of 256MB I have set
    Processes
    User Count CPU Memory
    mysqld mysql 1 3.0% 365 MB
    varnishd nobody 1 0.2% 94 MB
    php-fpm7.1 mpxcvqczjz 2 4.7% 86.4 MB
    varnishd root 1 0.0% 81.7 MB
    apache2 www-data 11 0.0% 33.7 MB
    sensu-client sensu 1 0.0% 14.5 MB
    newrelic-daemon root 1 0.0% 10.6 MB
    nginx www-data 1 0.9% 8.84 MB
    smtp postfix 2 0.0% 8.09 MB
    bounce postfix 2 0.0% 7.59 MB
    fail2ban-server root 1 0.1% 4.97 MB
    apache2 mpxcvqczjz 1 0.1% 4.47 MB
    nrsysmond newrelic 2 0.1% 4.15 MB
    systemd root 1 0.0% 3.35 MB
    pickup postfix 1 0.0% 3.3 MB
    php-fpm7.1 root 1 0.0% 1.88 MB
    apache2 root 1 0.0% 1.56 MB
    ntpd ntp 1 0.0% 1.54 MB
    systemd-journal root 1 0.0% 1.51 MB
    qmgr postfix 1 0.0% 908 KB
    vnstatd vnstat 1 0.0% 900 KB
    sshd root 1 0.0% 812 KB
    master root 1 0.0% 508 KB
    cron root 1 0.0% 496 KB
    systemd-logind root 1 0.0% 389 KB
    rsyslogd root 1 0.0% 356 KB
    monit root 1 0.1% 328 KB
    memcached nobody 1 0.1% 248 KB
    dbus-daemon messagebus 1 0.1% 136 KB

    Plugin Author Shareaholic

    (@shareaholic)

    @laserjobs can you email me the domain/site ID? We can check if the crawler was active during that time for the site. jay at shareaholic.com

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.