Support » Plugin: Wordfence Security - Firewall & Malware Scan » Server Error 500 while Wordfence is active

  • Resolved Andreas

    (@andioh)


    I’m facing random Server Error 500’s when the plugin is activated. Once I disbale it, the site works fine.
    This is what I found in the diagnostic.
    Please see the image attached.

    Screenshot

    Thanks for helping out!

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 15 total)
  • I had the same problem, turns out wordfence was exhausting the memory. Clearly others have the same problem so hope the fix it asap

    Hey @andioh,

    I’m sorry to hear that you’ve run into this.

    We’re currently tracking the issue. In our previous cases fully resetting Wordfence has resolved the issue. However, before doing this can you please share your server/system information? Also, please run a Diagnostics report before and after resetting Wordfence.

    Please let me know.

    Thanks,

    Gerroald

    Thread Starter Andreas

    (@andioh)

    Hi @wfgerald,

    thanks for your reply. I actually have reset the settings already, however with no luck.
    If you provide me your mail address I’ll forward the report directly from the diagnostic tab to you.

    Thank you,
    Andreas

    I guess I have the same issue too. This is error from the WP log:

    [13-Jun-2020 16:45:39 UTC] [Cloudflare] ERROR: [CLIENT API] Array
    (
        [type] => response
        [reason] => Internal Server Error
        [code] => 500
    )

    A bit strange is that this host has several WP sites sharing the same IP, all have wordfence (and cloudflare), but only one site fails. When I rename the /wordfence/ folder the site is fine.

    Thread Starter Andreas

    (@andioh)

    @yellofish
    Same on my end. I’ve running 3 wordpress sites, all on the same server and with the same Wordfence setup.
    Only one site has this issue. The only diffrence is, that the site which is not working, is a “.com” domain. All others are “.de” domains.

    Just to exclude the *.com comment, I have 3 *.com site in that server and just one ain’t working.

    @andreas, you are using Cloudflare? (Not that that seem to matter, I have cloudflare / Litespeed on all domains)

    Thread Starter Andreas

    (@andioh)

    @yellofish no, I’m not using Cloudfare or anything like that.
    What I use is a caching plugin, if this matters. However, like said before, all my pages have the same setup behind.

    Hopefully this gets fixed soon. I have a bad feeling leaving Wordfence off on my side.

    I just updated my site plugins and started getting this same error. I could not access the admin panel. I had to shell in and manually disable wordfence. I re-installed it from the admin panel and immediately got the problem again. So I again had to manually disable it.

    So I have installed WP Security.

    If it helps, I manage 2 sites, one hosted on godaddy and one hosted on telus. Only the one on godaddy is having the problem. As I said in my previous post, WP Security works fine but wordfence does not.

    I enabled debugging and re-installed the plugin now that is not active and I just get this error when I try to activate it:
    Plugin could not be activated because it triggered a fatal error.

    Noting in the logs… at least nothing in the debug log… if you want me to look elsewhere just let me know as I can re-create this problem all the time.

    I also started having this problem on a few sites with the random error 500s and large memory use in my PHP-FPM pools. Reloading the page a few times usually gets it to load eventually. I disabled the plugin and as was found above re-enabling would trigger the fatal error message. So I dumped all the wordfence tables and I co enable the plugin again an reset it up and it currently does not appear to be having the problem anymore.

    • This reply was modified 1 year, 1 month ago by Endymion00. Reason: Added memory usage note

    I had a similar problem today with a white screen of death after updating my plugins. I did not update Wordfence which was already up-to-date but disabling Wordfence did stop the problem of the white screen of death.

    I restored my site and DB from a pre-update backup and updated each plugin individually to see if one of them was causing the problem. This time there were no problems after all the plugins were updated.

    The only other things I did differently before updating were I went to the Wordfence settings screen and accepted the new terms and conditions (didn’t do that before) and I purged all caches using W3 Total Cache.

    In the end I installed the Wordfence Assistant and used it to clear the WP Database, then I was able to activate the plugin and re-configure it from scratch.

    • This reply was modified 1 year, 1 month ago by burningthumb.
    Plugin Author WFSupport

    (@wfsupport)

    Thanks for reaching out. We’ve been investigating these reports and now think we have a cause and a solution.

    One thing to note, that if you see an error in your logs about running out of memory, it may not be the same issue. It might be a case of needing to allocate more memory to PHP. PHP memory is cumulative. That means the amount set in php.ini is shared between all your plugins, your theme, and WordPress, plus any other non-WordPress apps you have installed in the site folder. We recommend changing it to 256M and upgrading to PHP 7 or above, which introduced better memory handling. If that doesn’t help, please try one of the other solutions mentioned here.

    What we found is that on some sites the emailedIssuesList row in the wfconfig table had became too large from recording hashes of previously emailed scan issues. Reinstalling Wordfence fresh (where the data and database tables are removed) was fixing the issue but this lets us know exactly where the problem was.

    There are 2 ways of fixing this.

    1. If you are comfortable using MySQL queries you can issue this command using PHPMyAdmin in your hosting control panel:
    delete from wp_wfConfig where name = ’emailedIssuesList’;

    2. If you are not comfortable with running queries do this:
    Remove and reset Wordfence, using the Wordfence Assistant plugin to remove all tables and data and then reinstall the plugin.

    We are looking at a solution to prevent it from happening again and hopefully will include it in the next release.

    Thanks always for being patient as we worked diligently to solve this for our customers. Thanks as well for reaching out and providing valuable information to help us solve it. Let us know if this solves it for you.

    Plugin Author WFSupport

    (@wfsupport)

    This has been fixed in the latest version, 7.4.8.

    Tim

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Server Error 500 while Wordfence is active’ is closed to new replies.