Support » Plugin: If Menu » Server Error 500 after update to 0.6.1

  • Resolved sennaspy

    (@sennaspy)


    Hi,

    after update to version 0.6.1 i got a server error 500 to all sites.
    I deactivated if menu plugin and all working fine, so after installation of backup with version 0.6.0 it is running.

    PHP version is 5.3.29
    System Linux sh-70 4.4.0-81-generic #104-Ubuntu SMP Wed Jun 14 08:17:06 UTC 2017 x86_64

    WP version 4.8.1
    Theme Hueman 3.3.20

    Anyone there with the same problem?

    bye
    Falk

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Andrei Igna

    (@andreiigna)

    Hi,

    Thanks for letting me know about this. I’m testing the plugin with this configuration and get back with a reply

    Basically your use of [] for arrays is breaking sites hosted with earlier versions of php 5 – please either check for php7 or lower the php compatibility level.

    Web hosts (hostgator, cough) suck at upgrading their PHP and we really don’t have the ability to change this.

    Yes, I agree that ALL WordPress plugins should remain backwards compatible with PHP5 until such time as PHP7 is a viable option (not enough support in PHP7 to force people to migrate to it yet). This is the same mistake that Drupal made with D7 and D8, and it’s imperative not to have WordPress plugin developers make the same mistake.

    I have spent time making sure my WordPress plugins are all backwards compatible, so I don’t think its too much to ask. Usually, it’s just a matter of using the legacy array notation. 😉

    Cheers,

    Brandon

    @andreiigna I forgot to include the specific error in my case is:

    Parse error: syntax error, unexpected ‘[‘ in /home/123123/public_html/wp-content/plugins/if-menu/if-menu.php on line 112

    Plugin Author Andrei Igna

    (@andreiigna)

    There’s a new small update for the plugin which will fix this issue.

    Sorry about the inconvenience, the next updates will be tested more thoroughly 🙂

    Very nice. Thank you for the quick response! 🙂

    Great performance Andrei, installation done and running.
    Thank you for quick support 🙂

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.