Support » Plugin: Elementor Page Builder » Server Error (403 Forbidden)

  • Resolved ragondin

    (@ragondin)


    Hi!

    I’m new to wordpress and elementor 2.0.5 and I’m having a really odd issue with the english version of the about page of the website I’m currently working on.

    So whenever I type “or” “and” in an elementor text edit section, I can no longer update it. The text box becomes greyed out and when I click on the update button I get:

    Server Error (403 Forbidden).

    – I have rollbacked to 1.9.8 but the issue remained.
    – When I use a wordpress text edit box, it updates fine.
    – I deactivated all plugins but that did not solve the issue.

    If anyone has encountered this issue or has a solution, that’d be of great help!

    Thank you!

    Rgdn

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 19 total)
  • Hi,

    This can be caused by different things.

    If you have some sort of security plugin like wordfence, it may “think” your action is dangerous and block it. In this thread: https://wordpress.org/support/topic/403-potentially-unsafe-error/ you can read what to do to fix this.

    If that does not help, this article might help: http://www.wpbeginner.com/wp-tutorials/how-to-fix-the-403-forbidden-error-in-wordpress/

    Annie

    Thanks Annie for your reply,

    I have no security plugin installed.

    These are the currently active plugins:

    – Addons for Elementor
    – Custom Fonts
    – Elementor
    – Elementor Addon Elements
    – Header Footer Elementor
    – NavMenu Addon For Elementor
    – Polylang
    – Snazzy Maps
    – UpdraftPlus – Backup/Restore

    Would there be any reason as to why “and” and “or” specifically cause issues, and not another word?

    And, again, it’s only an issue in an elementor text edit box (or elementor header edit box), the wordpress text edit box does not cause the issue.

    Conerning the WPbeginner article, I did get a new .htaccess file. My issue only arises when trying to update an edited page, not when accessing a webpage. I also checked that my file permissions are as indicated in the article.

    Any other suggestions?

    Many thanks,

    Rgdn

    Very strange indeed, that this only happens with those two words!
    I saw you have a multi languale site/Polylang.

    Could it be, it does not recognize these words….strange.
    I will try it in a test site, see if this happens too.

    Have you done all these steps by the way:
    https://wordpress.org/support/topic/please-read-before-you-post-an-issue/

    Just tried to replicate this but no issue’s:
    https://logologics.nl/webshop-starter/reviews/

    I could just type and use these words with elementor text element and it did not grey out and could update just fine.

    THere must be some of the third party plugins that causes this strange behaviour.
    Let me know if you followed steps as stated in the link, to see if that goes away if some or all other plugins are disabled. Switch themes…

    Thank you for your replies!

    – So Elementor and WordPress are updated.

    – I desactivated all plugins, then reactivated just elementor but the issue remained. Does deleting a plugin in the wordpress menu permanently remove it from the wp-content file? Could the remains of a plugin be responsible for the conflict?

    – I downloaded WP fastest cache and purged the cache, no difference.

    – I use the Astra theme, I switched to twenty fiftheen but without any success.

    – Finally, I went in my config.php and since the server host is a japanese service, the file had a lot of japanese in it. There was no instance of WP-DEBUG so i created one as follows: define( ‘WP_DEBUG’, true );

    as the end of the file, I have no idea if I did it right or if it changed anything.

    – As for Polylang, whether I edit on a french or english translation page, the issue remains the same. The french equivalent to “and” and “or” do not have any issue.

    I really do not know what to do.

    Would it be useful to just restart everything, and uninstall wordpress? In such a case, would I be able to put back my edited pages back as it currently is?

    Many thanks,

    Rgdn

    Hi,

    This is really odd, never heard of this before.
    Remains of a plugin could possible still cause some harm, not sure but it could I suppose. If you go into cPanel of your host: phpMyadmin you can see all the tables in your database. Ususally a plugin has a prefix in there that should refer to it to recognize it, so you could try and find out if there are some leftovers.

    However, if this is ONLY happening in the about page, you might save a lot of time by deleting that page completely ) also delete from trash! and start that page all over again. You might just get lucky that it is gone.

    Ofcourse, whatever you do, always make sure you have a backup you can revert back to!

    Annie

    Hi,

    I wish this issue was only happening on the about page, I tried editing other pages and the issue remains. I created a new page but that did not change anything either.

    I’m not sure my host gives me acces to phpMyadmin. I do have a page about php, where it lets me change the php version and some of its functionalities. Would there be anything there for my problem?

    Rgdn

    Hmmm as I never heard or encountered this particular issue, I actually do not know. However it would seem odd that the php version would mess this up.

    Php should however be above version 7, but you had that covered right?
    Youmight want to ask your host too. As it is chinese who knows that has something to do with it, but agian that is a wild quess, I have no clue at this point what can cause this.

    Is there a way you can migrate your site to another host/server to see if that makes a difference? I would at least ask the host if they have a clue on how this can happen?

    Oh, but as you state there is no issue if you use the core text editor. Why not use that one instead of Elementor?

    Okay so the php version is on 5.2 (CGI version). Should I change to 7.1? And would that imply major changes of any sort?

    And I do not really have the means to change to another host right now, I’m not actually the owner of the site. I’ll definitively have a chat with the owner though, maybe considering a host based in europe ;D.

    Rgdn

    pingram

    (@pingram3541)

    First perform a backup if you haven’t already and then yes you should upgrade up to at least 7.1, typically provided through one’s cpanel or by contacting your web host technical support team and making the request. It can typically be modified interchangeably within seconds. Anyone logged in will likely get logged out since php services restart.

    These are all the requirements the server needs to meet to let Elementor work at its best: https://docs.elementor.com/article/38-requirements

    You should indeed change to 7.1 but make sure to have backups before doing so.
    I have 50+ sites running with Elementor on php 7. all well.

    However if you have some plugins that are not yet compatible with php7 you might get in trouble so make sure to have a backup.

    I think most of the plugins in your list should be compatible by now. This one however: https://nl.wordpress.org/plugins/snazzy-maps/ was not updated for more then a year, so that might be a bit dangerous. I try to avoid plugins that are not maintained for a long time, that’s asking for trouble!

    One more question though.
    You say this happens in the English translation right?

    What happens if you use those same words in another language version?

    Also another note:

    -Consider adding SSL certificate to the site ( non hhtps sites will get red flags in browser saying the are not secure )

    – Consider using a theme like OceanWP that plays very well with Elementor,
    It has enough options so you wont need an extra nav plugin etc.

    Okay thank you for you replies! It’s great to see a community that helps newbies like me.

    About the backup, what would be the best way to backup my website? I have backups through Updraft, but would it be safer to do a ‘manual backup’?

    To answer your last post Annie, I tried in both the French and English translations, and the error appeared for both.

    Rgdn

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Server Error (403 Forbidden)’ is closed to new replies.