WordPress.org

Support

Support » Plugins and Hacks » server does not support encryption

server does not support encryption

  • purplebabyhippo
    Member

    @purplebabyhippo

    I have used wp-online backup on 2 previous sites both with ecryption, however on my 3rd site I am getting this message:
    “Your server does not support encryption
    Encryption requires the php-mcrypt extension with AES or DES cipher support and a compatible message digest framework (php 5.1.2 where it is builtin, php-hash or php-mhash). Encryption is highly recommended and you should consider contacting your host regarding these requirements”
    And under Decrypt Backup:
    “Encryption requires the php-mcrypt extension with AES or DES cipher support and a compatible message digest framework (php 5.1.2 where it is builtin, php-hash or php-mhash).
    Your server does meet these requirements, therefore you cannot this plugin installation to decrypt any encrypted backups.”
    I am using the same host (123-reg.co.uk) & the same version of wordpress on all sites.
    Do you know why this 3rd site won’t allow encryption?

    http://wordpress.org/extend/plugins/wponlinebackup/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Online Backup
    Member

    @driskell

    Hi purplebabyhippo,

    Can you provide the information from the Help & Support section?

    I wonder if your other sites are running on PHP 5 and this 3rd one is configured to be PHP 4 or something for one reason or another. The mcrypt plugin is widely available on most web hosts, and we only require the mhash if you’re on PHP 4, and it is usually the mhash that ends up missing in these instances (it’s a not as widely available). On PHP 5 it’s all builtin to PHP so we only need the mcrypt, which as said is widely available

    Jason

    kpkmiss
    Member

    @kpkmiss

    Hello!

    I urgently need some help because my site is also telling me that encryption is unavailable. I am wondering how I can access this, to be able to do a backup? (We are changing servers, and there is no one for me to contact regarding any access codes. Would there be a plugin that can get me access for encryption to run, and thus for a safe backup to be possible?)

    Lastly, what are the repercussions of choosing not to encrypt, but still backing up the site? Would this be my last resort?

    Please help!!!

    Plugin Author Online Backup
    Member

    @driskell

    Hi kpkmiss,

    Not encrypting just puts you at risk of the backup getting intercepted. However, this is highly unlikely to happen. It also means if you do online backup it will sit on our servers unencrypted – whether that’s acceptable to you or not is up to you (we have physical security as well alongside the usual network security any company would have.)

    You won’t be able to use encryption without the php-mcrypt module and only your host will be able to set this up.

    Jason.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘server does not support encryption’ is closed to new replies.