Support » Plugin: WebP Converter for Media » Server configuration error

  • Resolved jakublw

    (@jakublw)


    Hey,

    I have server based on Nginx on Google Compute Engine, and I have installed
    and configured GD library, but when I’m in settings I see:

    Redirects on your server are not working. Check the correct configuration for you in the plugin FAQ. If your configuration is correct, it means that your server does not support redirects from the .htaccess file or requests to images are processed by your server bypassing Apache.

    In this case, please contact your server administrator.

    Any ideas, why ?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Mateusz Gbiorczyk

    (@mateuszgbiorczyk)

    I’m reading this, and checking our configuration with your screen, and all for GD library looks this same.

    Plugin Author Mateusz Gbiorczyk

    (@mateuszgbiorczyk)

    @jakublw, do you have anything written about GD in the error message? No, so I do not understand why you focus on that. You’re using Nginx, right? What did you do after installing the plugin?

    @mateuszgbiorczyk Sorry for my laconic question, it was night :X

    Yes, so I have server based on Nginx.

    After I install your plugin I’m checking my php configuration, to compare my configuration with yours.

    And I see, I have a GD library, and all rules with GD library are this same as yours.
    I’m checking, another plugin to WEBP, and there my GD library looks good, and I can test convert img via this library, on this plugin. But I wanna use your plugin, because I’m testing it on my another sites, and there are looking good.

    Can I send to you my phpinfo result ?

    Plugin Author Mateusz Gbiorczyk

    (@mateuszgbiorczyk)

    @jakublw, please forget about GD. If you had any problem with the GD library, you would receive the appropriate message. The error you see is not related to the library.

    I asked you to read the thread I linked to. The thread says to read the plugin FAQ. You did it? In the plugin FAQ, you even have a special “Configuration for Nginx” question. There you will find more answers on how to configure the server for the plugin to work properly.

    @mateuszgbiorczyk Sure, you have right.

    In /etc/nginx/mime.types I have image/webp webp;
    And on /etc/nginx/sites-available/
    I’m adding your location rule, and after that I’m restarting nginx, and still is this error

    Redirects on your server are not working. Check the correct configuration for you in the plugin FAQ. If your configuration is correct, it means that your server does not support redirects from the .htaccess file or requests to images are processed by your server bypassing Apache

    Plugin Author Mateusz Gbiorczyk

    (@mateuszgbiorczyk)

    @jakublw, I checked the configuration for the Nginx server again. I set up a new server and did the entire procedure using these instructions. I was able to run WordPress and installed my plugin.

    Then I received a error message in plugin settings that redirects are not working. This is normal as Nginx requires manual configuration. Then I did the configuration settings for the plugin and everything works. The error is gone and the pictures are displayed in WebP.

    I updated the “Configuration for Nginx” question in the plugin FAQ. I have added some information there that you should pay attention to. The configuration itself works as it was.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.