WordPress.org

Support

Support » Plugins and Hacks » Custom Sidebars » [Resolved] Serious Sidebar Issue

[Resolved] Serious Sidebar Issue

  • Hoping someone can help, this is driving me round the bend. I have a page on my site that has always been working fine, I’m not sure what happened but now there is some seriously strange behavior.

    Page – http://www.wmdstudios.co.uk/machete-comp
    Plugins used – wordpress.org/plugins/custom-sidebars/

    Previous page set up: Main content as is currently, custom sidebar set using left side bar only, no right sidebar.

    Issues:
    – Left custom sidebar stopped working, it will leave a space where the side bar should be but no content is present.
    – Adding a right custom sidebar is the same as above.
    – Unless I have the default right sidebar active on the page, no javascript buttons will work on the page.
    – If I include an iframe in the page, as I have, instead of showing the sidebar on the right, it shows below the page content extremely large / full page width as if on mobile.
    – Existing pages on the site are not suffering these issues – custom left sidebars are working and iframes are in use without casing any issues.
    – Any new pages I create seem to suffer from the issues described.

    Please help!

    Thanks.

    https://wordpress.org/plugins/custom-sidebars/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Contributor Predrag Dubajic WPMU DEV Support

    @wpmudev-support1

    Hi @dominic_ks,

    Sorry to hear of the problems you are having.

    I have a page on my site that has always been working fine, I’m not sure what happened but now there is some seriously strange behavior.

    Have you changed anything recently on your site like adding / updating plugin / theme / WordPress or editing plugin settings?

    Kind Regards,
    WPMU DEV

    David

    @ugotsta

    WPMU DEV Support Staff

    Hi there @dominic_ks,

    Hope you’re well today! 🙂

    We’d love to assist further if you’re still having trouble with this. But also, with the recent plugin updates, perhaps that sorted it for ya?

    Just let us know if we can help further, we’ll be here to assist! 🙂

    Cheers,
    David

    Hi David,

    Thanks for the reply, also thanks to WPMU DEV, apparently I didn’t get notified of your response when you posted!

    Have sorted this now, found that when using some of the default minify settings in W3TC, pages with certain Java apps weren’t displaying custom sidebars properly. I solved this by spending quite a bit of time setting my minify settings more specifically.

    Also, I later realised that when previewing unpublished posts with custom sidebars, the sidebar would appear blank, but then would be visible on the live post one published. This just made for even more confusion when I was investigating the problems I was having!

    Cheers.

    Plugin Contributor Predrag Dubajic WPMU DEV Support

    @wpmudev-support1

    Hi @dominic_ks,

    Awesome, great to see you got that sorted and thanks for sharing the bottle neck of the issue and the solution in the community.

    I hope the solution you have shared will help others in the community facing the same issue.

    You are most welcome here, if we can be of any further assistance please don’t hesitate to ask 🙂

    Cheers,
    WPMU DEV

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] Serious Sidebar Issue’ is closed to new replies.
Skip to toolbar