Support » Plugin: NextScripts: Social Networks Auto-Poster » Serious problems occurred

  • After updating to version 4.3.27, I have a serious problem when posting.
    Not linked to SNS.

    • This topic was modified 3 weeks, 5 days ago by narururu.
Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author NextScripts

    (@nextscripts)

    It would be very helpful if you tell us what exactly is not working or what error message you are getting. There could be many different issues or errors, and we can’t help you without knowing which one you got.

    Thread Starter narururu

    (@narururu)

    The error message is as follows (original text is in Japanese):

    WordPress version 6.0.1
    Current theme: ORION (version 3.5)
    Current plugin: NextScripts: Social Networks Auto-Poster (version 4.3.27)
    PHP version 7.4.27

    An error of type E_ERROR was caused in line 63 of the file /home/xxx/public_html/wp-content/plugins/social-networks-auto-poster-facebook-twitter-g/inc-cl/tw.api.php. Error message: Uncaught Error: Cannot use assign-op operators with string offsets in /home/xxx/public_html/wp-content/plugins/social-networks-auto-poster-facebook-twitter-g/inc-cl/tw.api.php:63
    Stack trace:
    #0 /home/xxx/public_html/wp-content/plugins/social-networks-auto-poster-facebook-twitter-g/inc/nxs_class_ntlist.php(512): nxs_class_SNAP_TW->doPostToNT()
    #1 /home/xxx/public_html/wp-content/plugins/social-networks-auto-poster-facebook-twitter-g/inc-cl/tw.php(317): nxs_snapClassNT->publishWP()
    #2 /home/xxx/public_html/wp-content/plugins/nxs-snap-pro-upgrade/nxs-snap-pro-upgrade.php(41) : eval()’d code(47): nxs_doPublishToTW()
    #3 /home/xxx/public_html/wp-content/plugins/social-networks-auto-poster-facebook-twitter-g/inc/nxs_functions_engine.php(46): nxs_v4doSMAS2()
    #4 /home/xxx/public_html/wp-content/plugins/social-networks-auto-poster-facebook-twitter-g/inc/nxs_functions_wp.php(463): nxs_snapPublishTo()
    #5 /home/xxx/public_html/wp-includes/class-wp-hook.php(307): nxs_snapLogPublishTo()
    #6 /home/xxx/public_html/wp-

    Plugin Author NextScripts

    (@nextscripts)

    Please update your plugin to the latest version 4.3.28. This problem has been fixed there.

    Thread Starter narururu

    (@narururu)

    After updating to version 4.3.28, it would not link to Twitter and the following message appeared.


    {“client_id”:”xxxxxxx”,”detail”:”When authenticating requests to the Twitter API v2 endpoints, you must use keys and tokens from a Twitter developer App that is attached to a Project. You can create a project via the developer portal.”,”registration_url”:”https://developer.twitter.com/en/docs/projects/overview”,”title”:”Client Forbidden”,”required_enrollment”:”Standard Basic”,”reason”:”client-not-enrolled”,”type”:”https://api.twitter.com/2/problems/client-forbidden”}

    This may not be an error, but if Twitter API v2 is required you should make that known in advance. It will take some time to get a developer account and in the meantime, I will have to downgrade to version 4.3.26.

    Plugin Author NextScripts

    (@nextscripts)

    This is already answered few times in the support section and here https://www.nextscripts.com/known-issues/ as well.

    Twitter made a change to its API. Starting from July 15, 2022 every app must be in the Project. Please go to https://developer.twitter.com/en/portal/dashboard and attach your App to a Project. (Create a project if you don’t have one yet). See the link for more details.

    PS: Downgrading to .26 (or below) will help (we don’t know for how long) with apps that were created before July 15, 2022. Any Twitter app created on or after July 15, 2022 will NOT work with it.

    • This reply was modified 3 weeks, 2 days ago by NextScripts.
Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this review.