The Support Forums will be in read-only mode for a scheduled maintenance window on 01 September 2016 14:00 UTC - 20:00 UTC. More information.

Serious Problem with posts in WordPress 2.5 (30 posts)

  1. wildview
    Posted 8 years ago #

    There appears to be a major problem when publishing a new post with V2.5. After upgrading I can no longer publish a post. Every time I publish one it just results in the following error message returned “Your attempt to edit this post: "The Post" has failed. I have never seen this problem before until upgrading. The failed post is copied to the draft section and if I go to the draft and publish it from there it works. I wished I could go back to 2.3 since it always worked, but I know that isn’t possible now. Has anyone else seen this problem and is there something I can do to resolve it on my end.

    One thing I did do is use Word 2007 to post the blog and it failed too. I’ve use it before and it worked with earlier versions. Could this of screwed something up with 2.5 so that now you can’t even publish within the WordPress editor or maybe its some kind of security problem? Like I said above once it fails it makes a draft copy and you can publish from there which is a pain. There is something wrong and I need to fix it, so could someone pleasssssssssse help me.


  2. scotto15
    Posted 8 years ago #

    I have the same error. Any answers would be nice.


  3. grandeabobora
    Posted 8 years ago #

    Same error here. Help, please!

  4. scotto15
    Posted 8 years ago #

    I think its something with the plugins. I disabled all plugins and it seemed to work fine.

  5. lcf
    Posted 8 years ago #

    Same error on my clients' wordpress.

    @scotto15: any idea which plugin caused the error?

  6. domramsey
    Posted 8 years ago #

    I get that one randomly too.

  7. scotto15
    Posted 8 years ago #

    Well when i activate any of the plugins i get the error. not just one of them.

  8. anttijn
    Posted 8 years ago #

    Same problem here.

    The interesting part is that I had the old ajax-referer-fix plugin in my plugins folder(never worked for me in 2.3). Now the plugin causes the automatic draft saving to fail (red box with -1 appears) in 2.5. The real news is that with that plugin on I dont get the "Your attempt to edit this post" error message!

    So, it would seem to me that the problem is with the ajax referer!
    I'm just starting to check the pluggable.php for the new ajax referer function.

    Edit: propably turning on the ajax referer fix plugin in 2.5 will create some safety issues, but maybe someone with more knowledge about the whole wpnonce thingy will find this helpfull. Just to add my server has safemode on and it insists putting the port number (www.address.net:80) behind the site url. Removing the port number will cause the site to break down. I had problems with the same ajax referer in the older versions especially with deleting things from lists (posts, comments...). I always suspected that it had something to do with the address that ajax referer uses, maybe it has a problem with the port number?

  9. anttijn
    Posted 8 years ago #

    It seems that the only real solution the plugin creates is that it dies :)
    Anyway, there is some problem with the new ajax referer function.

  10. anttijn
    Posted 8 years ago #

    Two new things I noticed.
    1. If I disable the autosave function saving works. I did this simply by escaping the "wp_enqueue_script('autosave');" line from post-new.php.

    2. I also noticed that when this problem occurs also the preview function won't work. The reason to this is the value of the href: "%EF%BB%BFhttp://www.address.net:80/?p=191&preview=true".
    Notice the odd string "%EF%BB%BF" in the beginning. Now, if I try to preview and remove that string after pushing the preview button the preview works without a problem. So, it would seem that there could be a similar address related problem with the saving?

    EDIT: The string actually seems to be a byte order mark. Could the problem be with a file that has bom in it? Still, why does everything work fine when i disable all my plugins? And yes, I checked that all my plugin files are saved w/o BOM.

    I would really like to hear comments from someone more familiar with the code.

  11. anttijn
    Posted 8 years ago #


    At least for me the problem was with the byte order mark.
    I used this tool to check all my wordpress files for BOM and what do you know few of my plugin files actually had BOM in them. I opened those files and saved them again without BOM (note that in some cases I had to do it few times before the file actually was saved w/o BOM).

    After that everything works! The preview buttons href doesn't have the bom string in the beginning and there is no problems with saving.

    Hopefully others with the same problem will find this helpfull!

    EDIT: even tiny mce is working now, I use FCKeditor cause I used to have problems with the tiny mce. Who knows, maybe BOM in some files affects even tiny mce?

  12. jimmie65
    Posted 8 years ago #

    I've tried the tool and can't find the same issue. But trial and error has shown errors with at least 2 plugins: Customizable permalinks and WordPress Database Backup. Deactivating them lets me post again. (Both Yahoo plugins.)

  13. starriley
    Posted 8 years ago #

    My post/write link does not even show up inside of 2.5 admin area? any one can help appreciate it.

  14. kernow
    Posted 8 years ago #

    My main site is Windows hosted, though I have another which is Linux hosted and 2.5 works far better (full wysiwyg editor and all). The problem is with the ajaxed upload screen, which in my main site using IE7 descends below the taskbar making button clicking impossible. At least in Firefox I can attempt to upload an image. If I do I get a 'image failed upload test' kind of error message, before finding a copy in my image gallery. Attempting to insert that image then becomes a problem as it won't insert using the familiar insert image method, resulting in the copying and pasting of link code to make it work.

    A real bug making posting a problem.

  15. chotroi75
    Posted 8 years ago #

    Just downloaded a v2.5 for first time use and get stuck also with the uploading of image. Don't have any plugins yet.
    Even it says that the uploading has failed, the image is uploaded into my library. So to be able to post an image, I then go to libray, click on the permalink of the picture, then get the URL of the image, copy anf paste into the poste.
    It's a painful process just to post an article, but can bypass the problem by the time being.

  16. kranenburgesq
    Posted 8 years ago #

    AnttiJN, could you please elaborate on what 'ajax' and 'BOM' are?

    Jimmie65, I can deactivate the standard backup plugin, but how do I activate the 2.5 auto-save then?

    In short, really, can someone respond how to get saving and publishing again, explaining it for everybody here? Thank you!

    (Also see my topic on the same problem, which explains exactly the problem I have and where I link to similar Trac-reported as-of-yet-unresolved bugs: http://wordpress.org/support/topic/169852?replies=7#post-737269)

  17. kranenburgesq
    Posted 8 years ago #

    It works again!
    I haven't tried AnttiJN's tool (see above), but I did find the two plugins Jimmie65 referred to (also above). And it worked for me, I can save again and I can publish again. I don't know how it works, but forgive me, for now I don't care. (Just too bad I do get the ugly default URLs now, but hey, at least there are new ones to be created of those.)

    How I did it
    To deactivate the Customisable permalinks, go to Settings, Permalinks. There, select Default and Save Changes. At first it didn't save and I got a blank page but after a few tries it did take the change. You'll see the message on the same page that says so.

    Then to deactivate the database plugin, that is easier still. Go to Plugins and find the WordPress Database Backup one. Deactivate it by clicking on Deactivate. Or you may simply deactivate all your plugins in one go with the relevant button there.

    Now you too can save and publish again. This fix I hope is just temporary, because I do prefer the custom URLs and at some point, I will want to back up the database again. Thanks.

  18. adriari25
    Posted 8 years ago #

    I've got a little problem with the "insert/edit image" button, when you click that icon the pop up appear but it's white, without the fields to insert the URL. That's happend in Firefox But in IE6 is all ok!
    Insted, when you use the "Add an image" button, a new pop up window appears with the fields to put an URL but when you click the button "insert into post" nothing happens.
    Bye Manolo
    from webandana.com: the art of climbing in Friuli - Italy

  19. heathergm
    Posted 8 years ago #

    Had the flashing button, super slow unusable edit page issue - the answer for me at least seems to be that I had missed updating the settings file in the root directory when manually upgrading from 2.5 to 2.51 - specifically the newest wp-settings.php file (4/21/08) includes the following on line 335 that is missing in earlier versions
    the newest files include this code at lines 335-342

     * It is possible to define this in wp-config.php
     * @since 2.5.0
    if ( !defined( 'AUTOSAVE_INTERVAL' ) )
    	define( 'AUTOSAVE_INTERVAL', 60 );

    I suspect this to be the cause of the whacked out javascript loop that killed my browsers.
    Comparing files from the broken blog with a new install on both the same host and another hosting company that doesn't use fantastico but offers one click install it became apparent that the files were different, so even if you replaced it as part of your upgrade getting the newest version from a 2.5.1 download post april may be the answer.

    Before this I also tried the following to fix this issue with no success:

    - Deleted the files in wp-content/uploads/js_cache
- Set the WPLANG define in wp-config.php to 'en'

- Cleared all the caches on browser
    - Updated Tiny MCE using the following

    √1. Download the latest version of TinyMCE from the offical site:
    √2. Unzip the following files into wp-includes/js/tinymce:
- tinymce\jscripts\tiny_mce\tiny_mce.js
- tinymce\jscripts\tiny_mce\tiny_mce_popup.js
- tinymce\jscripts\tiny_mce\tiny_mce_src.js
    √3. Delete the files in wp-content/uploads/js_cache. √Clear all the caches on browser, √manually reload this URL on your blog: /wp-includes/js/tinymce/tiny_mce_config.php to verify

    Also removed all dev and live blog cookies before restarting browser
    Again removed new files from wp-content/uploads/js_cache

    Downloaded and installed tinymce-advanced plug in - turned it on, repeated all cache clearing, turned it off cleared caches etc. no love

    So reading this post at http://trac.wordpress.org/ticket/6844 led me to suspect that my upgrade had not been as thorough as i thought it had. Like in this post my browsers were telling me they were stuck in a continual loop looking for admin-ajax.php and the new settings file with the interval definition in it seems to have ended that issue which allows for speedy typing and easy posting.

    I am still waiting to hear whether any other authors on this blog are still having issues but i think this is the fix and hope it helps someone.

  20. MaartenN
    Posted 8 years ago #

    does somebody have a clear answer to solve this problem?
    I'm having lots of problems with this with some plugins, when i activate these, i get the message that my attempt to edit the post failed.
    I can't really find a solution for this problem, have you already solved this?

  21. blubikbeneenvis
    Posted 8 years ago #

    'just upgraded and had the same problem. Still having minor problems but AnttiJN's trick worked for me:
    1. If I disable the autosave function saving works. I did this simply by escaping the "wp_enqueue_script('autosave');" line from post-new.php.
    Did the same thing in page-new.php as well.

  22. maxblast
    Posted 8 years ago #

    same probleme here, so i also disabled the autosave functions in post-new.php and page-new.php. it works!

  23. julieanne-vanzyl
    Posted 8 years ago #

    I have a similar but worse problem. Since upgrading, none of my old posts display on the Blog, None of the Pages are displayed.

    All I have is the sidebars and the header - the footer does not display either. Although, when I remove the code to display posts within the Index.php, the Footer is displayed.

    Please see full details here with the code I'm using.


  24. julieanne-vanzyl
    Posted 8 years ago #

    PS has anyone tried uninstalling wordpress, then Installing the new version from the beginning?

  25. julieanne-vanzyl
    Posted 8 years ago #

    I just realised! It's no use uninstalling because then we would lose all the data in the database. Sorry.

  26. rawalex
    Posted 8 years ago #

    It's another bug / feature in wordpress: upgrades aren't handled very well, there is no real mechanism similar to install to do an upgrade directly.

    When you upgrade, what you should do it delete pretty much everything except your themes, plugins, and any files like htaccess and data files you may have created, and your wp-congig.php... then upload the new version.

    Files or functions get dropped over time (often without notice) but they may still be included or used by plugins and similar, which can cause problems.

  27. Furtoosh
    Posted 8 years ago #

    I had the same problem. I followed AnttiJN's solution and it worked. One of my plugins was the problem. It was TimesURL.at Sociable Plugin.

  28. Furtoosh
    Posted 8 years ago #

    The problem appeared again. I disabled autosave in wp-admin/post-new.php by commenting it out:


    And the problem was solved! I do not get the error message now.

  29. lifestyler
    Posted 7 years ago #

    Got this problem since i upgraded to wp 2.7. still no solution? I dont feel like editing manually in core files cause that will require me to do so on every upgrade....

  30. rhagl
    Posted 7 years ago #

    I had the same problem. The solution seemed to be a "fix" that solves 90% of all wordpress problems I encounter: make sure the wp-config.php is encoded and formatted correctly (my hosting environment is Centos5):

    1. Encoding: UTF-8, Lineendigs: Windows (CR+LF)
    2. Formatting: no unnecessary empty lines in the file (this fixed the posting problem for me)

    A good Windows tool for these changes is the free Notepad2.

    Hope this helps anyone.

Topic Closed

This topic has been closed to new replies.

About this Topic