Support » Requests and Feedback » Serious Problem with posts in WordPress 2.5

  • There appears to be a major problem when publishing a new post with V2.5. After upgrading I can no longer publish a post. Every time I publish one it just results in the following error message returned “Your attempt to edit this post: “The Post” has failed. I have never seen this problem before until upgrading. The failed post is copied to the draft section and if I go to the draft and publish it from there it works. I wished I could go back to 2.3 since it always worked, but I know that isn’t possible now. Has anyone else seen this problem and is there something I can do to resolve it on my end.

    One thing I did do is use Word 2007 to post the blog and it failed too. I’ve use it before and it worked with earlier versions. Could this of screwed something up with 2.5 so that now you can’t even publish within the WordPress editor or maybe its some kind of security problem? Like I said above once it fails it makes a draft copy and you can publish from there which is a pain. There is something wrong and I need to fix it, so could someone pleasssssssssse help me.

    Thanks…

Viewing 15 replies - 1 through 15 (of 29 total)
  • I have the same error. Any answers would be nice.

    thanks

    Same error here. Help, please!

    I think its something with the plugins. I disabled all plugins and it seemed to work fine.

    Same error on my clients’ wordpress.

    @scotto15: any idea which plugin caused the error?

    I get that one randomly too.

    Well when i activate any of the plugins i get the error. not just one of them.

    Same problem here.

    The interesting part is that I had the old ajax-referer-fix plugin in my plugins folder(never worked for me in 2.3). Now the plugin causes the automatic draft saving to fail (red box with -1 appears) in 2.5. The real news is that with that plugin on I dont get the “Your attempt to edit this post” error message!

    So, it would seem to me that the problem is with the ajax referer!
    I’m just starting to check the pluggable.php for the new ajax referer function.

    Edit: propably turning on the ajax referer fix plugin in 2.5 will create some safety issues, but maybe someone with more knowledge about the whole wpnonce thingy will find this helpfull. Just to add my server has safemode on and it insists putting the port number (www.address.net:80) behind the site url. Removing the port number will cause the site to break down. I had problems with the same ajax referer in the older versions especially with deleting things from lists (posts, comments…). I always suspected that it had something to do with the address that ajax referer uses, maybe it has a problem with the port number?

    It seems that the only real solution the plugin creates is that it dies 🙂
    Anyway, there is some problem with the new ajax referer function.

    Two new things I noticed.
    1. If I disable the autosave function saving works. I did this simply by escaping the “wp_enqueue_script(‘autosave’);” line from post-new.php.

    2. I also noticed that when this problem occurs also the preview function won’t work. The reason to this is the value of the href: “%EF%BB%BFhttp://www.address.net:80/?p=191&preview=true”.
    Notice the odd string “%EF%BB%BF” in the beginning. Now, if I try to preview and remove that string after pushing the preview button the preview works without a problem. So, it would seem that there could be a similar address related problem with the saving?

    EDIT: The string actually seems to be a byte order mark. Could the problem be with a file that has bom in it? Still, why does everything work fine when i disable all my plugins? And yes, I checked that all my plugin files are saved w/o BOM.

    I would really like to hear comments from someone more familiar with the code.

    Success!

    At least for me the problem was with the byte order mark.
    I used this tool to check all my wordpress files for BOM and what do you know few of my plugin files actually had BOM in them. I opened those files and saved them again without BOM (note that in some cases I had to do it few times before the file actually was saved w/o BOM).

    After that everything works! The preview buttons href doesn’t have the bom string in the beginning and there is no problems with saving.

    Hopefully others with the same problem will find this helpfull!

    EDIT: even tiny mce is working now, I use FCKeditor cause I used to have problems with the tiny mce. Who knows, maybe BOM in some files affects even tiny mce?

    I’ve tried the tool and can’t find the same issue. But trial and error has shown errors with at least 2 plugins: Customizable permalinks and WordPress Database Backup. Deactivating them lets me post again. (Both Yahoo plugins.)

    My post/write link does not even show up inside of 2.5 admin area? any one can help appreciate it.

    My main site is Windows hosted, though I have another which is Linux hosted and 2.5 works far better (full wysiwyg editor and all). The problem is with the ajaxed upload screen, which in my main site using IE7 descends below the taskbar making button clicking impossible. At least in Firefox I can attempt to upload an image. If I do I get a ‘image failed upload test’ kind of error message, before finding a copy in my image gallery. Attempting to insert that image then becomes a problem as it won’t insert using the familiar insert image method, resulting in the copying and pasting of link code to make it work.

    A real bug making posting a problem.

    Just downloaded a v2.5 for first time use and get stuck also with the uploading of image. Don’t have any plugins yet.
    Even it says that the uploading has failed, the image is uploaded into my library. So to be able to post an image, I then go to libray, click on the permalink of the picture, then get the URL of the image, copy anf paste into the poste.
    It’s a painful process just to post an article, but can bypass the problem by the time being.

    AnttiJN, could you please elaborate on what ‘ajax’ and ‘BOM’ are?

    Jimmie65, I can deactivate the standard backup plugin, but how do I activate the 2.5 auto-save then?

    In short, really, can someone respond how to get saving and publishing again, explaining it for everybody here? Thank you!

    (Also see my topic on the same problem, which explains exactly the problem I have and where I link to similar Trac-reported as-of-yet-unresolved bugs: http://wordpress.org/support/topic/169852?replies=7#post-737269)

Viewing 15 replies - 1 through 15 (of 29 total)
  • The topic ‘Serious Problem with posts in WordPress 2.5’ is closed to new replies.