Support » Plugin: Custom Permalinks » Serious Problem with Permalinks

  • Resolved Lightpurple

    (@pamkaur14)



    Hi,

    I am having a serious problem with custom permalinks. I cannot seem to get it to work with new pages and posts that I am creating. Also, when I go in to edit any existing page or post and save it, it is then coming up with a 404 error even though the permalink is correct. This is what is happening:

    1. I create a new post/page

    2. For a page, I select a parent page. For a post, I select the category.

    3. I select save draft. The custom permalink that comes up is correct. For example, if the slug is “example” and the category/parent page is “category-example”, the permalink that shows up is …/category-example/example. If I click on “Preview” everything is fine.

    4. Then when I do more edits and click Save Draft again, I notice that the permalink changes to “…./category-example/category-exampleexample”.

    5. Even after I edit the permalink back to “…/category-example/example” and save again…then click Preview, it takes me to a 404 not found page.

    I have no idea what is going on!!! I am too scared to edit any of my pages now because every time I edit anything, the page becomes a 404 not found.

    I have tried this several times and every single time it is the same result.

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author Sami Ahmed Siddiqui

    (@sasiddiqui)

    Hi Lightpurple,

    It’s sad to know that you are facing issue with permalink. I would like to ask some questions to you.

    1. how long you are using this plugin? It seems you are using this plugin from a long time if it’s correct so, is it working fine before?
    2. Have you installed any plugin recently?
    3. Have you changed your theme or something in the current theme?

    I suggest you to please disable all the plugins except this and try to add/edit any post/page. If it works fine so, enable the plugin one-by-one and check the issue. On which plugin, the issue occurs again that’s mean the issue is with that plugin

    If disabling plugin doesn’t help you so, please change your theme and disable all other plugins except this one and check the issue whether it persist or not.

    Let me know your findings

    Thanks,
    Sami

    Hi,

    I have been using the plugin only recently. I have tried disabling the latest plugins I installed since installing Custom Permalinks. However, I think I have tried to narrow down the problem to something in particular and it seems to be a problem with the custom permalink itself.

    1. I create a new post call “Hello”. I set the category as “example”. I click Save Draft.

    2. The permalink that comes up is “……/example/2017/6/hello”.

    3. I then change the permalink to “…../longer-example/oneword/hello”. I click Save Draft. The page becomes a 404 not found.

    4. I change the permalink to “…./longer-example/2017/6/hello”. I click Save Draft and the page is visible again.

    So it seems to be the change from “2017/6/” to “oneword” that is causing the problem. I am not a developer. You will probably be better able to explain what is happening here.

    One other thing I have noticed is that if I try to change the slug on the main “All Posts” screen by clicking on “Quick Edit” then editing and updating the slug that way, when I actually go in to Edit the Post, I notice that the custom permalink doesn’t change.

    Cheers.

    There is another issue I have discovered and I am wondering if this is what is causing the problem.

    When I update the permalink to a custom permalink, the “slug” of the page doesn’t change. So say I change the custom permalink from “…./category/example-1-2-3” to “…..category/example”, the slug still remains as “example-1-2-3” rather than “example”. This is the case even if I manually go in and manually update the slug to “example”. When I click on “update”, the old slug still remains.

    Could this be the problem?

    Is there any solution to this? The structure of a lot of my pages and posts is based on custompermalinks. If you are unable to find a solution to this, I need to know now and delete your plugin immediately.

    Plugin Author Sami Ahmed Siddiqui

    (@sasiddiqui)

    @pamkaur14 , AS per your scenario, please change the permalink and publish the post. So, the permalink works for you.

    Don’t change the permalink for Draft Posts. Permalink works for only Publish Posts.

    Let me know, if you need some other help.

    Thanks,
    Sami

    I have tried this and still the same.

    As per my post in this thread https://wordpress.org/support/topic/trailing-slash-and-not/, I believe the issue is your plugin and nothing to do with other plugins or permalinks or anything else.

    No reply but now not necessary.

    Dear Plugin Author,

    After hounding my VPS support team, including asking them to review all of the rewrite rules, security rules and anything else in the WordPress installation that could be causing a problem with the 404 error, this is the conclusion they came to:

    https://pasteboard.co/GAFcrax.jpg

    This was after the support team working for 2 days to identify the issue….the poor buggers finally came up with the cause of the problem, which, as I previously said, is your plugin.

    Suffice to say, I am going to be deleting your plugin and never using it again. I will now have to restructure my site with new URLs and redirects.

    Lucky for me my site is fairly new with a manageable amount of pages and posts. I feel sorry for anyone with a huge website who is using your plugin.

    I am having the same issue. For a lot of time I just “put up with it”, and found it would stop if I selected the permalink box before updating a post. Now more recently this does not fix it — it continually changes permalinks from for example “category/page/” to “/category/categorypage/”.

    This is super irritating, because every time I update a page, I then have to re-update it because I need to fix the permalink error.

    Please could you guys look into this? It’s the plugin, not anything else. Why would the plugin generate this extra string — equal to the parent page/directory path?

    Plugin Author Sami Ahmed Siddiqui

    (@sasiddiqui)

    @usernamenottaken Please elaborate your issue.

    I have created a page with the title “Page 1” then created another page with the title “Page 2” and selected the “Page 1” as parent page of “Page 1”.

    After that i have selected the Permalink box of “Page 1” and updated the page 2 -3 times but it doesn’t make any issue for me.

    Does i am missing something? Please elaborate your problem and tell me that how i can regenerate this issue on my end.

    Thanks,
    Sami

    Hi. You may have made some typos here, e.g. you say ‘and selected “Page 1” as parent page of “Page 1″‘ — you must have meant to say Page 2 as the latter page, but instead of guessing what you did exactly, please see the hypothetical example below:

    Assume my site is website.com.

    1. Now let’s say I have a page called “definitions” (website.com/definitions/), which lists a bunch of definitions for various terms. A user can click on a definition for more information.

    2. I might then have a page called “WordPress definition”, and this could be a child of the definitions page. Example URL: website.com/definitions/wordpress-definition/

    3. Now, once I edit “WordPress definition”, after clicking save, I can see the permalink box in WordPress as showing: website.com/definitions/definitionswordpress-definition/

    3.1. I now have to manually edit out the extra string in the URL to fix it. This always works the second time round, but it’s as if the permalink box *MUST* change upon every save — whether for better or worse.

    For example, if I *chose* to change the permalink, there would be no error. For example, if before saving I changed the permalink to website.com/definitions/joomla-definition/, this would work just fine. It’s when I leave it as it is (WordPress definition) that the box wants to generate an extra string for no reason.

    NOTE: This does not happen 100% of the time. But it happens maybe 80-90% of the time. Yes, very strange.

    To try replicating the issue, avoid touching the permalink box at all. Just make edits to a page and then hit save, and do that a few times (edit and save, edit and save — don’t touch the permalink box). Maybe this will work.

    Any luck with replicating the issue? I wonder if there’s some kind of plugin conflict here. I might have to create a staging site and disable each other plugin sequentially, but I don’t think there is a conflict — there’s nothing else that affects my permalinks to my knowledge.

    Please do let me know if you make any progress here as it’s pretty bad. I feel like learning PHP properly, just to find a solution to this!

    Plugin Author Sami Ahmed Siddiqui

    (@sasiddiqui)

    @usernamenottaken Thanks for your continues providing feedback.

    I have followed you scenario but not able to reproduce the issue on my end. I have created a post and update it 12 times without touching permalink field but issue doesn’t occur.

    I have created a page as well and updated it 10 times without touching permalink field but, issue doesn’t occur in it as well.

    Regards,
    Sami

    Sorry for the lack of feedback, but good job on the last few updates! I think you might have fixed this — whether inadvertently or intentionally. It seems as though the error has completely gone for me? I’ll make sure to reinvestigate if it appears again, but it’s great so far.

    Many thanks for your efforts, and appreciate the support + plugin.

    Plugin Author Sami Ahmed Siddiqui

    (@sasiddiqui)

    @usernamenottaken That’s a great news that your issue has been resolved 🙂

    Regards,
    Sami

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Serious Problem with Permalinks’ is closed to new replies.