WordPress.org

Forums

[resolved] Serious problem (15 posts)

  1. Inget Namn
    Member
    Posted 3 years ago #

    Im running a webshop and suddenly after just adding a product I couldnt get access to the dashboard.
    Im using the latest WP version and Wootique theme with Woocommerce plugin. No other plugins.
    The error message is " you dont have proper aouthority to access this page" or similar (its in swedish).

    I googled this error message and got a few hints on what to try but none worked.
    I tried adding a new admin but same result.
    What could be wrong and shouldn't wordpress be a little more stable then this?

    I hope someone can give me some tips!

    [ Please do not bump, it's not permitted here. ]

  2. Inget Namn
    Member
    Posted 3 years ago #

    I think I know what the problem is but I dont know enough about database to fix it.
    I believe the problem is in wp_options and in wp_user_roles that lack informatin about administrator
    Could this be correct? And if so, what do I ad to solve it?

  3. Krishna
    Volunteer Moderator
    Posted 3 years ago #

    It can be because of the Wootique theme. Did you try to upgrade the theme?

  4. Inget Namn
    Member
    Posted 3 years ago #

    I got the latest version

  5. kmessinger
    Forum Moderator
    Posted 3 years ago #

    You will find support for your theme here, http://www.woothemes.com/support/

    Because it is a commercial theme it is hard to find support in this forum as we are unfamiliar with all the "bells and whistles". You paid for support when you purchased the theme.

  6. Inget Namn
    Member
    Posted 3 years ago #

    Its not a theme problem though but thanks

  7. kmessinger
    Forum Moderator
    Posted 3 years ago #

    Its not a theme problem though but thanks

    How do you know?

    Have you tried:
    - deactivating all plugins (yes, all) to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s). If you can't get into your admin dashboard, try resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.
    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    In any event, this is the policy on premium themes.
    http://codex.wordpress.org/Forum_Welcome#The_Bad_Stuff

  8. Inget Namn
    Member
    Posted 3 years ago #

    I have tried another theme yes and deactivating plugins.
    I have so far tried everything I could find about this problem including adding another admin but nothing works.

  9. kmessinger
    Forum Moderator
    Posted 3 years ago #

  10. Inget Namn
    Member
    Posted 3 years ago #

    I just told you I tried that.

  11. kmessinger
    Forum Moderator
    Posted 3 years ago #

    I just told you I tried that.

    I am referring to the user meta in the link that is in the database and would give you information on your question,
    I believe the problem is in wp_options and in wp_user_roles that lack informatin about administrator

  12. Inget Namn
    Member
    Posted 3 years ago #

    Thats just how to add another admin.
    The wp_options is a different table.

    It looks like this:

    a:3:{s:8:"customer";a:2:{s:4:"name";s:4:"Kund";s:12:"capabilities";a:3:{s:4:"read";b:1;s:10:"edit_posts";b:0;s:12:"delete_posts";b:0;}}s:12:"shop_manager";a:2:{s:4:"name";s:12:"Butiks├Ągare";s:12:"capabilities";a:33:{s:4:"read";b:1;s:18:"read_private_pages";b:1;s:18:"read_private_posts";b:1;s:10:"edit_posts";b:1;s:10:"edit_pages";b:1;s:20:"edit_published_posts";b:1;s:20:"edit_published_pages";b:1;s:18:"edit_private_pages";b:1;s:18:"edit_private_posts";b:1;s:17:"edit_others_posts";b:1;s:17:"edit_others_pages";b:1;s:13:"publish_posts";b:1;s:13:"publish_pages";b:1;s:12:"delete_posts";b:1;s:12:"delete_pages";b:1;s:20:"delete_private_pages";b:1;s:20:"delete_private_posts";b:1;s:22:"delete_published_pages";b:1;s:22:"delete_published_posts";b:1;s:19:"delete_others_posts";b:1;s:19:"delete_others_pages";b:1;s:17:"manage_categories";b:1;s:12:"manage_links";b:1;s:17:"moderate_comments";b:1;s:15:"unfiltered_html";b:1;s:12:"upload_files";b:1;s:6:"export";b:1;s:6:"import";b:1;s:18:"manage_woocommerce";b:1;s:25:"manage_woocommerce_orders";b:1;s:26:"manage_woocommerce_coupons";b:1;s:27:"manage_woocommerce_products";b:1;s:24:"view_woocommerce_reports";b:1;}}s:13:"administrator";a:1:{s:12:"capabilities";a:5:{s:18:"manage_woocommerce";b:1;s:25:"manage_woocommerce_orders";b:1;s:26:"manage_woocommerce_coupons";b:1;s:27:"manage_woocommerce_products";b:1;s:24:"view_woocommerce_reports";b:1;}}}

  13. kmessinger
    Forum Moderator
    Posted 3 years ago #

    If you look at the user roles data in the options table you will see it is theme and plugin specific. And to me (I only have a couple of others to compare to) it looks extremely short. Do you have a db backup?

    If not you should check with your host as they may have one. You also should pursue support at the woo site.

  14. Inget Namn
    Member
    Posted 3 years ago #

    If you scroll right the rest is there. I compared it to my other sites and it looks pretty much the same but this one lacks the administrator tags in the beginning and I do not know what to add there. I tried but that rendered in a error message.

  15. Inget Namn
    Member
    Posted 3 years ago #

    I solved it.
    I simply copied the information in option_value from my other website and now I can log in as admin again.

Topic Closed

This topic has been closed to new replies.

About this Topic