WordPress.org

Support

Support » Installation » Serious Install Problems

Serious Install Problems

  • I’m trying to install WordPress on my host’s OpenBSD server (Apache 1.3.27, PHP 4.2.3, 3.23.55) and having a terrible time of it. I’m by no means a newbie to the Unix world, installing CMSs, etc. I’ve tried the following steps with with the current stable release, a nightly build, and a CVS checkout from about 10 minutes ago. Nothing works.
    I go through the install-config.php script and, regardless of having permissions to write to the necessary directory, it fails to install a wp-config.php. I then create this file manually and proceed to the install.php page which displays nothing. No errors, no output at all. Nothing. And yes, the file has the right permissions to be executed by the web server and all that. So I can’t go any further from there.
    It’d be swell if somebody had a clue for me, ’cause I’m at a loss.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You say you created the file manually… did you just make a blank file, or actually add the information from wp-config-sample.php (or whatever the name is), changing things where appropriate?

    I figured that it’s something with my host, which has had its share of problems. Moving to a new host.

    Nah, my host was RootRoute, and is now Dr2. In all honesty I’ve had so many problems with RootRoute that I skipped diagnosing this problem and used this as a justification to jump ship to another host. Life’s too short!

    Hmm… it appears all I had to do was change the perms on wp-config.php from 644 to 664 and voilĂ  — it worked. The blog is now set up.

    Sorry, I should clarify that last post, so it’s a little more helpful to anyone else who might encounter the same problem:
    Any files that the webserver (including PHP, CGI and any other webform)
    will write to or modify must:
    – be 644 (and directories 755), if you know the USER that the webserver runs as, and you must also change the ownership on the files/directories to that same user. For apache, this is usually “nobody”, “apache” or “www”, depending on how it’s been set up.
    – be 664 (and directories 775), if you know the GROUP that the webserver runs as, and you must also change the group ownership on the files/directories to that same group. This is usually the same as the username. For example, when I ftp into my wife’s weblog site, I see the following:
    230-User <username> has group access to: <username>
    I hadn’t expected the wp-config.php file to need writing to, so I had set it to 644, but decided to change it to 664 just in case. And that worked. Anyway…
    – be 666 (and directories 777), if you either don’t know the user/group of the webserver, or you don’t have permission to change the file/directory permissions to their ownership. Note that this means anyone with access to this website, either through login or a badly-written PHP script, can overwrite these files and directories, which is bad.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Serious Install Problems’ is closed to new replies.