Support » Plugin: Stripe For WooCommerce » SEPA not working

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author mr.clayton

    (@mrclayton)

    Hi @digitalcreed,

    Do you not have a billing email field on your checkout page? The Stripe plugin automatically includes the customer’s email address as part of the Sepa source creation.

    Are you seeing a notice on your checkout page when you attempt to use SEPA?

    Kind Regards,

    Thread Starter digitalcreed

    (@digitalcreed)

    Hi mr.clayton. I dont have a billing email field because the payment is for internal purpose. Thats why I made a default email adress for all orders.
    Thats the error message:
    “When creating or updating a Source with mandate[notification_method] email (default for debit networks that require notifying the payer), you must provide a valid owner[email].”

    Plugin Author mr.clayton

    (@mrclayton)

    Hi @digitalcreed,

    At this time there isn’t an easy way for you to remove the mandate option from the SEPA source since it’s created client side.

    Is this on your checkout page or an order pay page?

    You can use WooCommerce filters to auto-populate the billing_email field however and you could add your admin email. That will ensure it’s not empty when the source is created. Let me know if you want to go that route and I will show you how.

    Kind Regards,

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘SEPA not working’ is closed to new replies.