Support » Plugin: SEOPress, on-site SEO » SEOPress removes the content from the category page for my blog

  • Resolved scdayton

    (@scdayton)


    If I activate the SEOPress plugin then my blog category page (https://stephendayton.com/seo-agency-blog/) spits out the following error message.

    This page doesn’t seem to exist.
    It looks like the link pointing here was faulty. Maybe try searching?

    So, now no one can find my blog posts.

    If I deactivate the SEOPress plugin then the category page https://stephendayton.com/seo-agency-blog/ works and all my posts show up correctly.

    I also tried activating the SEOPress plugin, but disabling all of the Dashboard sections within the SEOPRess plugin (Tiles & METAS, Sitemaps, Social, Analytics, and Advanced) and that didn’t work either which tells me it’s not a particular setting, but the plugin as a whole that keeps blog posts from showing up on my blog category page.

    I don’t want to have to remove the SEOPress plugin, but I need a fix. I can’t have it throwing up an error page for my blog.

    Any help would be appreciated.

    Regards,

    Stephen

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Benjamin Denis

    (@rainbowgeek)

    Hi,

    go to SEO > Advanced.

    Is “Remove /category/ in your permalinks” option checked?

    If yes, try to flush your permalinks.

    Or if you want to keep /category/ in your URLs, unchecked it, save changes and flush permalinks.

    Clear your cache if you have one.

    Thread Starter scdayton

    (@scdayton)

    You rock Ben!

    Yes, I had the “Remove /category/ in your permalinks” option checked and I had tried clearing my cache locally and at the CDN level as well and none of those efforts had work.

    This time using your advise I flushed the permalinks and it solved the problem. That’s something I’ve never heard of before so thank you.

    Plugin Author Benjamin Denis

    (@rainbowgeek)

    No problem 😉

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘SEOPress removes the content from the category page for my blog’ is closed to new replies.