Support » Plugins and Hacks » [Resolved] SEO Tools Pro – Some tools not working

[Resolved] SEO Tools Pro – Some tools not working

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Scott Hendison


    The plugin path you’re showing is not for the free plugin at WordPress, but is for the pro version from our membership site.

    We have received your support ticket there and will respond now, so I’m closing this thread…

    Hi I get the same error when running a url check.

    Fatal error: Call to a member function assign() on a non-object in /home/admin/public_html/i-consultancy.be/wp-content/plugins/seo-automatic-seo-tools/index.php on line 142

    I use the free version of this plugin on our website.
    Can you please help to fix this?

    Kind regards

    Plugin Author Dzynit


    Following the path in the error you saw: /wp-content/plugins/seo-automatic-seo-tools/index.php
    Add global $smarty; to the beginning of that index.php file. We’ll be releasing a new SEO Tools version in the near future, to deal with this issue.
    I thank AllenPayne for pinpointing the fix. I needed to do a little research on the problem and get a confirmation that it was not a plugin conflict before implementing.

    Thanks and let us know if that corrects the problem.

    No doesn’t solve the problem;

    Now I get:

    global $smarty;
    Fatal error: Call to a member function assign() on a non-object in /home/admin/public_html/i-consultancy.be/wp-content/plugins/seo-automatic-seo-tools/index.php on line 143

    I’ve put global $smarty; right after <?php on the index.php

    Kind regards

    Plugin Author Dzynit


    global $smarty; shouldn’t be printing to the screen, so will you try one more thing for me?

    Move the global $smarty; down to the line 143. This will be right before this piece of code:

    	$smarty->assign('extend_header', '
    		<script src="themes/' . $settings['app']['theme'] . '/js/seoinspector.js" type="text/javascript"></script>

    If that still doesn’t work, would you allow me access to trouble shoot? I’ve not been able to duplicate the error anywhere yet, so I need to see things on a site that it is showing. I would need both a wp-admin login and also ftp to troubleshoot, but please don’t post that in here. You can send to heather (at) searchcommander.com

    Hi Heather,

    That doesn’t solve the problem either.
    Now the page doesn’t even load the regular content with the button, it just gives the error line again.

    I’ve created a admin account for you to take a look.


    Plugin Author Dzynit


    I don’t see an email from you yet. I had mis-typed heather at first, but edited the post right away. Could you double check that you sent it to heather (at) searchcommander.com please? Let me know what email address your sending from too just in case it might pop into my spam folder.

    Thanks, Heather

    Plugin Author Scott Hendison


    Heather does now have the WP access after using the “lost password” feature, but she needs FTP too. We’re happy to try and fix things for you @tkquincy if you want to provide FTP?

    Hi Heather,

    I’ve sent you the FTP details for troubleshooting.

    Kind regards,

    Hi Heather,

    i’ve tried changing the theme back but that gives me the same error again.
    I’ll check with my hosting if they have something that blocks smarty.

    Kind regards;


    I contacted my hosting about the global smarty, this is what I got back:

    The following error appears on your site:

    Fatal error: Call to a member function assign() on a non-object in /home/admin/public_html/***********.be/wp-content/plugins/seo-automatic-seo-tools/index.php on line 141

    This is an error in the code of the plugin. If the original developer of the plugin is unable to correct this bug, you would need to hire and independent developer to help you with this code error. Alternatively, you may be able to find an alternate plugin that does not have errors.

    Are you sure you can’t fix it?

    Plugin Author Scott Hendison


    @tquincy – I’ve been seeing the emails you’ve had with Heather (and would you PLEASE reply all on all communication) and at this point we cant get anywhwere.

    I’m almost positive Hostgator was one of the webhosts we tested with when the plugin was built so we’ll get an account and get it tested…

    (and PS can you please be sure to “reply all” on the emails between you and Heather?)

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Resolved] SEO Tools Pro – Some tools not working’ is closed to new replies.