Support » Theme: Omega » SEO Plugins not working with theme

  • Resolved leahjm77

    (@leahjm77)


    I have installed 2 different popular SEO plugins with this theme and neither are working properly. Every time I type in the page title and description for a page and update the page, the information I put into that area disappears and goes back to the default. I use these plugins with many other websites and have never had an issue so I think it’s the theme. Also, when I look at the page source for any of the pages it only shows the default title that’s put into the WordPress General settings, but no title in regards to each specific page or meta description or keyword tags based on what is put into the SEO plugins. Is there something in the theme files conflicting with this? Please advise asap.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Theme Author Han

    (@hwijaya)

    Can you tell me what plugin you use? It works fine with WordPress SEO plugin.

    Hi Han, thank you for your reply. I was just asked to add some SEO to a website that was built by someone else previously so I’m not familiar with it. I tried WordPress SEO and All in One SEO Pack. With WordPress SEO, after I type info into some of the fields and update the page it just goes back to all the fields being blank. The other one doesn’t work either. By default every page just shows the WordPress title put into the general settings and no meta description. I have never encountered this before. The site is running off the Omega theme but uses the Church child theme which was also created by yourself I believe. I went through all the customization settings for that theme and didn’t see anything that would conflict with working with an SEO plugin but I thought maybe there is something within the theme files.

    Theme Author Han

    (@hwijaya)

    Oh, that’s strange. I’ve been using Omega + WordPress SEO for all my projects and they work together. I’ll look into and will update you soon. Thanks for your report

    I have the same problem for my site is the SEO tools supposed to show up on the dashboard?

    Theme Author Han

    (@hwijaya)

    @snowammo, you are not using Omega. Please contact your theme author to check the issue

    I see it is not universal, thanks

    Thanks Han. I went through most of the pages with both popular SEO plugins and it seems the issue is only on the homepage. Any SEO settings for the homepage aren’t saved. So it almost seems to be overwritten by something else. I went through the SEO main settings and the theme customization settings and can’t see anything that would be causing it. The website is http://www.slashyourheatingcosts.com.

    Theme Author Han

    (@hwijaya)

    Can you try this: copy the content of your current homepage to create a new page to replace the current homepage? Then delete the old homepage.

    I’ve got the same problem, on all pages of my site with the Church theme.

    Theme Author Han

    (@hwijaya)

    Please try the latest version of Omega and see if that fix your issue. @leahjm77’s issue was fixed.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘SEO Plugins not working with theme’ is closed to new replies.