Support » Plugin: Yoast SEO » SEO Plugin not fully working

  • Resolved toofast

    (@toofast)


    WordPress version: 3.5.1
    WordPress SEO version: Latest

    I installed the plugin with no error.

    At Titles & Metas > Home – I added a Title and a Meta Description but Meta Description doesn’t show in the google results.

    When i create a post, the Meta Description doesn’t show in thee Google Results, just words from the post.

    Anyone had the same issue? Please help me.

    http://wordpress.org/extend/plugins/wordpress-seo/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Greymount

    (@greymountroadstarinternetnet)

    I would love some help with this too. My website has NO description on any search results pages (only my url). I thought I followed all the SEO instructions to the letter. Have looked at countless blogs/forum posts, tutorials….nothing gets to the bottom of it so far. If you get an answer somewhere else, please post here. Many thanks.

    Do you have <?php wp_head ?> at the end of </head> ?

    Greymount

    (@greymountroadstarinternetnet)

    I’m not the least bit technical, but I did find that, and yes. thx I discovered that google just picked up the description (after a week’s wait). Yahoo still hasn’t come around, and I’ve checked all the settings re. pinging that and other sites. I assumed WordPress and the most popular plug ins would not require this much of a learning curve, but that’s for another thread. 🙂 I clearly have more investigating to do.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘SEO Plugin not fully working’ is closed to new replies.