Support » Plugin: All in One SEO Pack » SEO Plugin doesn’t work properly

  • Resolved joshm101

    (@joshm101)


    It has been 4 weeks and none of my SEO plugins settings are registering with google.

    Not sure where to go from here. All the settings seem to be correct but google isn’t receiving meta desc, titles or keywords.

    Could you please help me.

    Thanks

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Contributor Arnaud

    (@arnaudbroes)

    Hi @joshm101, the plugin is working correctly but it takes time for Google to recrawl and reindex your website. Changes unfortunately happen over time and not instantly. As I mentioned before via e-mail, I would highly recommend you to verify your website in Google Search Consoel so you keep track of indexing – https://semperplugins.com/documentation/google-webmaster-tools-verification/

    Plugin Contributor Arnaud

    (@arnaudbroes)

    *Google Search Console

    joshm101

    (@joshm101)

    It is indexing the site but the settings I have made, e.g. Meta Titles, Descriptions per page and Keywords aren’t coming through and it’s been a month with no change when I check site:illawarrainuslation.com

    Not sure if I should keep waiting or get someone to try and figure out if there is a problem with the settings or setup.

    Plugin Author Michael Torbert

    (@hallsofmontezuma)

    WordPress Virtuoso

    For the most part, your titles and descriptions set are showing up for me in the results. I see in Google’s cache that you used to use a different SEO plugin which had different information. It takes time to change.
    If the SEO meta you want is in the source code, then All in One SEO Pack is doing its job.

    Sometimes, Google knows what you want to be displayed, and shows something else instead. You can read more about this here: https://semperplugins.com/documentation/why-doesnt-the-title-and-description-i-set-appear-in-search-results/

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.