Support » Plugin: The SEO Framework » SEO Bar tips not displaying

  • I asked for assistance with this and you instructed me to use Chrome but I am using Chrome (and have tried Firefox with this issue as well) but the result is the same. When I hover over the SEO bar in the Posts list I just get the Question Mark (?) not the tip as text which I was getting.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Sybre Waaijer

    (@cybr)

    Hello Keith,

    Thanks for reaching out to me here! There could be another script preventing the execution of subsequent scripts, or there could be a PHP error–which can be caused by anything–that prevents the output of our scripts.

    To test the PHP error, go to the page where the tooltip should be shown, and view the page’s source. If you can’t find a closing HTML tag at the very end of the source, there’s a PHP error.

    To test the JavaScript error, open the browser’s developer tools (F12 on Windows), and see if there are any errors. Note that PHP errors might cause extraneous JavaScript errors, thanks to absent resources.

    PHP debugging
    When you’ve found it’s a PHP error, please consult the WordPress debugging guide, specifically the WP_DEBUG part:
    https://codex.wordpress.org/Debugging_in_WordPress

    When debugging is enabled via WP_DEBUG, you should see the error pop up. This might not be very useful to non-developers, but you can roughly see what plugin or theme folder might’ve caused this.

    If you wish to know more on the debugging output, I kindly suggest replying to my mail with what you’ve found. It may reveal information you’d rather have undisclosed.

    Debugging JavaScript
    When you’ve found it’s a scripting error, you should see the file name at the right-hand of your screen in the developer tools. Hovering over the file name will reveal its path, and thus the conflicting plugin or theme.

    If you’ve found it’s an issue with TSF’ script, please make a screenshot of what you’ve found. I believe it should be safe to post here, but replying to my mail is fine too if you feel more confident in doing so.

    I hope this helps!

    Thread Starter keithtee67

    (@keithtee67)

    Thank you for the advice; unfortunately i have discovered that that was not the problem – the problem is the plugin has stopped working. I have uninstalled and re-installed, disabled all other plugins, run a db cleaner but it no longer works, the tabs in setup only highlight but do not change the displayed content so I have abandoned the product.

    Plugin Author Sybre Waaijer

    (@cybr)

    Hi Keith,

    I’m sorry it didn’t work out for you.

    I want to help you resolve this issue, but if you’ve given up… that’s ok 🙁

    I do understand that there’s a scripting issue, but I don’t understand how that could’ve suddenly happened — code doesn’t stop working out of the blue, but there’s environmental interference at hand.

    From your comments, you’ve tried disabling all plugins without success. Switching the theme is a bit more of a hassle, but that could also be the issue.

    You tried both Firefox and Chrome, do they have the same extensions active?

    I can assure you it’s not a database issue. Regardless, this is an edge-case — in two months of running v3.0.6, no other users have reported this issue.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘SEO Bar tips not displaying’ is closed to new replies.