Support » Plugin: Yoast SEO » SEO analysis shows “0 words”

  • Resolved erikbuchinger

    (@erikbuchinger)


    Today, I noticed the posts on my site have bad SEO scores, and under the analysis it says each of the posts we uploaded today have 0 words even though they’re roughly 500-word articles and doesn’t recognize any of the internal/external links. I’m wondering why this is and how I can fix it.

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Support devnihil

    (@devnihil)

    @erikbuchinger If your page has content and you are receiving the message of ‘The text contains 0 words’ this is typically due to the content of the page being created outside of the default WordPress editor. Some page builder plugins are not able to share the content created in them with the readability analysis feature of Yoast SEO.

    Can you let us know if you are using a page builder plugin such as Visual Composer, Site Origin, Beaver Builder etc to create your page’s content? The SEO and readability analysis feature scan sometimes not work correctly if you are using some kind of visual page builder, as they can cause the page’s content to not be accessible to the plugin due to it being created outside the functions of the standard WordPress page editor.

    We have additional information available on this issue at the following link: https://kb.yoast.com/kb/error-text-contains-0-words/

    Thread Starter erikbuchinger

    (@erikbuchinger)

    Yes, I am using Site Origin.

    Plugin Support suascat_wp

    (@suascat_wp)

    Hi @erikbuchinger

    It seems SiteOrigin has improved the compatibility with Yoast SEO analysis as per their recent release changelog:

    https://wordpress.org/plugins/siteorigin-panels/#developers

    Please make sure that you have an up-to-date version of SiteOrigin.

    Thread Starter erikbuchinger

    (@erikbuchinger)

    Yes, I have the most up to date version, and it’s not working.

    Same issue. Just having SiteOrigin Page Builder enabled for “posts” and not actually using it still causes Yoast to not detect text in Classic Editor. Disabling SiteOrigin for posts seems to work.

    frankopwintersportnl

    (@frankopwintersportnl)

    I have the same issue.

    It happens on posts in ‘classic editor’ modus.. without the use of any builder… funny because in posts built with SiteBuilder all works well..

    FYI SiteOrigin are investigating – https://github.com/siteorigin/siteorigin-panels/issues/811

    My site has site origin installed (and latest version) but for blogging we use the classic editor interface. Our blog posts are showing 0 words prior to publishing as well.

    • This reply was modified 1 year, 8 months ago by lifelightweb.
    frankopwintersportnl

    (@frankopwintersportnl)

    I have exactly the same issue as lifelightweb. Is there an update on this issue?

    Plugin Support Jeroen Rotty

    (@jeroenrotty)

    Hi @erikbuchinger,

    Thank you for your reply.

    As @stylishjm mentioned, the Site Origin developers are looking into this as it seems this is on their end. It looks like they have a fix ready and it might be included in their next release.

    Hi @lifelightweb & @frankopwintersportnl,

    Looking at the GitHub issue and the scope, this should be resolved with their upcoming fix as well. We hope that it will be fixed in their next release.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘SEO analysis shows “0 words”’ is closed to new replies.