Support » Plugin: Germanized for WooCommerce » Sendungsnummer in Customer Completed E-Mail

  • Resolved yunse

    (@yunse)


    Es geht um den Post: https://wordpress.org/support/topic/dhl-tracking-in-customer-completed-order-e-mail/

    Leider funktioniert es irgendwie nicht mehr, dass die Sendungsnummer in der Customer Completed E- Mail angezeigt wird, wenn ich Label erstellen drücke (Sei es auf der Orderseite oder bei Sendungen) und die Sendung auf Versendet gestellt wird und der Auftrag automatisch auf Fertiggestellt gestellt wird. Erst wenn ich es speicher und dann manuell die Customer Completed E-Mail verschicke oder manuell dann auf Fertiggestellt stelle geht es. Ich weiß, dass vorher funktionierte, muss wohl irgendwann durch ein Update verursacht worden sein.

    Mir scheint es so, als würde die Sendungsnummer nicht mehr vor dem versenden der Customer Completed E-Mail eingespeichert und ist daher im Moment des Verschickens noch leer. Weil nach dem alles gespeichert wurde, geht es wenn man die E-Mail manuell verschickt.

Viewing 8 replies - 16 through 23 (of 23 total)
  • agunda

    (@agunda)

    das testen ist nicht ganz so einfach. Du müsstest mehrere Dateien ersetzen:

    https://raw.githubusercontent.com/vendidero/woocommerce-germanized-shipments/master/src/Shipment.php
    –> ersetzen unter wp-content/plugins/woocommerce-germanized/packages/woocommerce-germanized-shipments/src/

    und

    https://raw.githubusercontent.com/vendidero/woocommerce-germanized-dhl/master/src/Automation.php
    –> ersetzen unter wp-content/plugins/woocommerce-germanized/packages/woocommerce-germanized-dhl/src/

    Grüße

    Gemacht und klappt bei mir (germanized pro). Danke!

    Plugin Author vendidero

    (@vendidero)

    Hi,

    der Loop ist merkwürdig. Wie gesagt, das müsstest du via Chrome Developer Tools debuggen bzw. schauen, was da los ist. Du kannst die Chrome Developer Tools einfach öffnen und dann ganz normal auf der Website navigieren.

    Grüße

    yunse

    (@yunse)

    Wie gesagt geht leider nicht, sehe Video: https://screencast-o-matic.com/watch/cYnfbxw2dL

    yunse

    (@yunse)

    geht allgemein auch nicht mit Touch, was wir unbedingt eigl. brauchen.

    Plugin Author vendidero

    (@vendidero)

    Also im Video geht das doch einwandfrei. Hast du mal statt in den Network-Tab in die Konsole geschaut ob dort Fehlermeldungen geloggt werden? Wenn das via Chrome Developer Tools funktioniert, könnte das ein Browser-Cache-Problem sein (der wird nämlich beim Aktivieren der Tools ggfs. deaktiviert).

    geht allgemein auch nicht mit Touch, was wir unbedingt eigl. brauchen.

    Was meinst du damit konkret?

    yunse

    (@yunse)

    Guck Dir das Video mal genauer an 😉
    Da funktioniert gar nichts! Wenn ich auf den “Erstellen” Button klicke nach dem die Lightbox kommt verschwindet die Lightbox und es passiert nix, das gleiche auf Handys und Tablets bzw. allen Touch Geräten. Das gleiche wenn ich in den Developer Modus wechsel da passiert das dann auch, deswegen kann ich die Funktion nicht testen weil der Button gar nicht anklickbar ist im Devoloper Modus, versuch es doch mal selber dann wirst du es sehen. Am besten auch nochmal mit Handy.

    Vielen Dank für den Support! 🙂

    Plugin Author vendidero

    (@vendidero)

    Hi,

    kontaktier mich doch bitte mal per Mail – ich kann das Problem lokal nicht reproduzieren.

    Grüße

    yunse

    (@yunse)

    E-Mail ist raus. 🙂

Viewing 8 replies - 16 through 23 (of 23 total)
  • The topic ‘Sendungsnummer in Customer Completed E-Mail’ is closed to new replies.