• Hello,

    its WP 5.4.2 and Better Notifications for WP 1.8.3. Today (as irratically before), the plugin sent our 2.500 mails to subscribers by trigger “New Post Published” for a post that was published 22th mai (3 weeks ago) and is unchanged since then. The mails got fired immediately after an admin login and were logged by GD Mail Queue.

    Do you have an idea, how that can happen? It happens like every second month, always for recently published posts (but not for NEW posts, they are all between 6-3 weeks old and unchanged) and always when logging in as admin.

    Best
    Marc

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author bnfw

    (@voltronik)

    Hi @mcian,
    Thanks for your message.

    My suspicion would be that your host is triggering wp_mail (or another action) off of the WP cron, which in turn is only triggered when someone visits your site, possibly even via login only.

    There’s no delay mechanism in BFNW so my thinking is that it must be something else delaying the emails from going out.

    Thread Starter jansass GmbH

    (@mcian)

    Actually, its no delay. The original sending from 22th may got sent on 22th may, right after publishing that post. But today, the SAME mailing got released, with no appearent reason: The post is old, was not queued (got sent already), status “published” was not set, not even edited the post…

    So why today? Why that post? Why not on every login?

    Can you do another wild guess ?

    Marc

    Plugin Author bnfw

    (@voltronik)

    Hi @mcian,
    How are you sending email from your site? Is it just via WordPress or are you using an SMTP plugin, or via a plugin to an SES?
    I’m still wondering if it’s a queue somewhere.

    Alternatively, caching could be causing the issue.

    Thread Starter jansass GmbH

    (@mcian)

    Well, i fear its GD Mail Queue running mad. Im sorry to have put this to your list, because the first mail originally got sent by your plugin. But the problem is somewhere else…

    Best
    Marc

    Plugin Author bnfw

    (@voltronik)

    Hi @mcian,
    Not a problem.

    Hope you get to the bottom of it 😊

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Sends Mails although it shouldn’ is closed to new replies.