Support » Plugin: SendPress Newsletters » Sendpress Newsletters PHP 7.2 compatibility errors

  • cjdegenn

    (@cjdegenn)


    Sendpress newsletters is producing errors when scanned for PHP 7.2 compatibility. The errors are related to mcrypt vs. openssl. Will there be an update to resolve this?
    We are using Version 1.9.11.26.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author itdoug

    (@itdoug)

    Yes. It’s on our list to fix.

    swish888

    (@swish888)

    Hello Support,

    I’m also having the same issue after running the plugin ‘PHP Compatibility Checker’ for PHP 7.2 compatibility. Current plugin version installed is 1.10.6.18.

    FILE: /public_html/wp-content/plugins/sendpress/classes/class-sendpress-base.php
    ——————————————————————————————————————————————————
    FOUND 4 ERRORS AFFECTING 1 LINE
    ——————————————————————————————————————————————————
    16 | ERROR | Function mcrypt_decrypt() is deprecated since PHP 7.1 and removed since PHP 7.2; Use OpenSSL instead
    16 | ERROR | Extension ‘mcrypt’ is deprecated since PHP 7.1 and removed since PHP 7.2; Use openssl (preferred) or pecl/mcrypt once available instead
    16 | ERROR | The constant “MCRYPT_RIJNDAEL_256” is deprecated since PHP 7.1 and removed since PHP 7.2
    16 | ERROR | The constant “MCRYPT_MODE_ECB” is deprecated since PHP 7.1 and removed since PHP 7.2
    ——————————————————————————————————————————————————

    Can you advise when we can expect a new update to come out so that it is compatible with php7?

    Kind regards

    • This reply was modified 6 months ago by swish888. Reason: Added current plugin version
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Sendpress Newsletters PHP 7.2 compatibility errors’ is closed to new replies.