Support » Plugin: SendPress Newsletters » Sendpress e-mail editor and problem

  • Resolved Ztone


    Hi guys

    I am experiencing a problem with the Sendpress editor in WordPress.

    When I press the Enter key, the text marker only jumps down one row. Doing the same in WordPress page or post editor, the marker jumps down 2 rows (<p>).

    If I press the enter key twice and write something that I would like to be a new heading (<h1>), as soon as I mark the new text and choose Heading 1 from the menu, the marked text jumps up one row. That’s all.

    On other occasions if I somehow am able to actually get it formatted as h1 (can’t replicate this systematically), it makes the complete previous paragraph also in h1.

    Really frustrating.

    First I thought it had something to do with my wordpress install or other plugins. I just went the long way around removing plugins, updating to the latest WP version, trying different options for content entering etc… nothing worked.

    Important to say, my wordpress visual editors work great, both for posts and for new pages on our site etc. I am using TinyMCE Advanced. Nothing more related to the editor window. And the TinyMCE advanced “buttons” are useable in the Sendpress editor as well.

    I have tried to inactivate the TinyMCE advanced, but it didn’t make any difference.

    Have any of you guys any idea of what could be causing this?


Viewing 7 replies - 1 through 7 (of 7 total)
  • Debug info:

    ### Begin System Info ###
    ## Please include this information when posting support requests ##
    Multi-site:               No
    SP Version:    
    WordPress Version:        3.8.1
    Platform:                 Windows
    Browser Name:             Chrome
    Browser Version:          32.0.1700.107
    User Agent String:        Mozilla/5.0 (Windows NT 6.1; WOW
    			  64) AppleWebKit/537.36 (KHTML, l
                              ike Gecko) Chrome/32.0.1700.107
    Database Tables:
    pbzwebsendpress_subscribers_event OK
    pbzwebsendpress_report_url OK
    pbzwebsendpress_subscribers_status OK
    pbzwebsendpress_subscribers OK
    pbzwebsendpress_list_subscribers OK
    pbzwebsendpress_queue OK
    Sending Method: 		  SendPress_Sender_Gmail
    PHP Version:              5.2.17
    MySQL Version:            5.5.30-cll-lve
    Web Server Info:          Apache
    PHP Memory Limit:         256M
    PHP Post Max Size:        64M
    WP_DEBUG:                 Disabled
    WP Table Prefix:          Length: 6 Status: Acceptable
    Show On Front:            page
    Page On Front:            START #31
    Page For Posts:           START #31
    Session:                  Disabled
    Session Name:             PHPSESSID
    Cookie Path:              /
    Save Path:                /storage/content/67/141267/
    Use Cookies:              On
    Use Only Cookies:         On
    POST_MAX_SIZE:            64MB
    WordPress Memory Limit:   40MB
    WP_DEBUG:                 Off
    DISPLAY ERRORS:           On (1)
    FSOCKOPEN:                Your server supports fsockopen.
    AddThis Smart Layers: 1.0.6
    Collapse-O-Matic: 1.5.7
    Contact Form 7: 3.7
    Display Posts Shortcode: 2.3
    Easy FancyBox: 1.5.6
    Exec-PHP: 4.9
    Google Analytics Dashboard for WP: 4.2.6
    Google XML Sitemaps: 3.4
    jQuery Updater: 2.1.0
    Preserved HTML Editor Markup: 1.5
    Really Simple CAPTCHA: 1.7
    SendPress: Email Marketing and Newsletters:
    SI CAPTCHA Anti-Spam:
    TinyMCE Advanced:
    UpdraftPlus - Backup/Restore: 1.8.8
    Use Google Libraries: 1.5.2
    W3 Total Cache: 0.9.3
    Wordpress Language: 1.1.1
    WordPress Meta Description: 1.5
    ### End System Info ###

    [Moderator Note: Please post log files between backticks or use the code button.]

    Plugin Author itdoug


    Could you put the full debug in the forum? Just leave out the URL. Haven’t seen this before.

    You are using chrome for windows, correct? Could you try a different browser as a test?

    Plugin Author itdoug


    Never mind on debug. Came through via email.

    Did you really disable all plugins? It shows several active now. I’m Wondering about W3 total cache too.

    Plugin Author itdoug


    Also, I can’t access your other csv forum. If it’s still an issue, email me the csv or a sample so I can’t test.

    Did you try this?

    Plugin Author itdoug


    Also, I can’t access your other csv forum. If it’s still an issue, email me the csv or a sample so I can’t test.

    Did you try this?

    Hi It Doug 🙂

    Thanks for your replies.

    I mainly use Chrome and it is with Chrome that I first noticed the issue. Since then, I have tried Firefox and IE with identical results. Let me just try it again… yep, still the same in both IE and Firefox.

    I did try this

    It actually worked. It imported 2387 subscribers (correct). I originally thought it had only imported 239, but just now noticed that it was 239 pages filled with subscribers 🙂

    Since disabling the plugins didn’t make a difference, I enabled the ones I needed afterwards. That’s why they were showing “active” in the debug info.

    W3 Total cache “should” only effect the front end of the site. Backend should be left untouched. However, I can do a second round of disabling the plugins and try it again.

    Noone else having similar issues and have found ways to fix it?

    Thanks a lot for your support! I love this plugin and tool. Would be absolutely great if this issue could be solved.

    Best regards,

    Plugin Author itdoug


    I’m glad you were able to get it imported using the alternate method. We don’t usually have very many problems with CSV imports. But on occasion there can be some strange encoding of the CSV file or strange line endings that could be difficult for the importer to deal with. Sometimes there are just problems with individual hosting setups that we can’t test. If you would like me to test importing your file into one of our systems, feel free to send me a copy. doug at sendpress dot com.

    If we have problems importing to our systems then there might be a way for us to fix it. Otherwise, that’s why the import alternative exists.

    Do I understand correctly that you are still having problems with the editor? I wonder if it could be your theme causing the problem since you have tested all the plug-ins. You may have already seen this knowledge base article, but just in case here is a link. Sometimes swapping out the theme as a test by activating a different one is a good way to eliminate things.

    Any additional screenshots or even a Jing video of the problem may help us figure out what’s going on in the editor.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Sendpress e-mail editor and problem’ is closed to new replies.