Support » Plugin: Knews Multilingual Newsletters » sending terribly slow

  • Resolved hsr



    thank you for this great plugin.
    Since a month i’m experiencing a problem in one of my website where i run knews plugin on wp 3.5.1. Everywhere else it works fine but in this one ( sending became really slow… I’ve been using this plugin for long time and everything was just perfect (always using wordpress CRON, even on the other websites).

    Since a month it takes weeks to send the same newsletter (about 6500 contacts i was used to reach in 2-3 days) and i also get thousands error on the report page.

    The same plugin on my other website works fine.
    I tried to uninstall and install it again but nothing changed.
    I also tried to use my webserver CRON but everything’s just the same.

    What can i do?

Viewing 11 replies - 1 through 11 (of 11 total)
  • Can anyone help me please?
    I’d appreciate it so much.

    <img src=’’ border=’0′ alt=”Schermata 2013 05 13 a 14 22 46″ />
    open source screen capture

    Hello! Please, ask some questions:

    About speed:

    What are the trigger method? CRON / JS-CRON / WP-CRON?

    This are a manual newsletter submission or automated newsletter submission?

    What are the amount of submits selected per iteration?

    About errors:

    Are you submitting with wp_mail() or SMTP?

    Kind Regards,
    Carles Reverter.

    Hi Carles,
    thank you for answering!

    Well, the trigger method is WP-CRON.
    I always use manual newsletter submission using SMTP.

    I’m sending just one newsletter a week and subscribers are 6500.

    Now i have this (
    newsletter star delivery on may 6th = > 6422 users = > still 49 %
    (no other delivery running at the same time)

    On another website i manage (
    newsletter star delivery on may 16th = > 5250 users = > 62 %

    Let me know if you need any other info.
    Thank YOU

    For a great amount of subscribers, CRON method is mandatory. WP-CRON doesn’t be triggered until you get a visit on your website (less website traffic sucks). I think this is the problem… you can also use the JS-CRON, leave a window opened and wait… if this solves the issue, I’m sure, WP-CRON is the cause.

    Kind Regards,
    Carles Reverter.

    Thank you Carles,

    i’ll try with CRON.

    Do you think i can change the method while the sending is running?
    Or is it better to stop, change and restart?

    Hi Carles,

    even with CRON it doesn’t seem to work.
    What can i check to make it work again?

    Do you have any other suggestion?

    Plugin Author creverter


    Yes, sorry for the delay…

    Go to Knews > Configuration> “Advanced” tab, you will find in the CRON option the amount of minutes from the last CRON call. Should be 10 minutes or less, somethimes 12 or 15 if the webserver is so bussy… if you see something like thousands of minutes, CRONJOB aren’t working…

    You can use JS-CRON trigger while CRON aren’t working. Here the tutorial about CRON:

    Carles Reverter.



    Hi Carles,

    thank you for your help.
    The thing is the company that host my website allows to call CRON only every 30 mins.
    And I am able to configure it only via a Schedule Task Manager.

    Check it out here:

    Please let know cause your plugin is not working anymore…

    Plugin Author creverter


    What means “Please let know cause your plugin is not working anymore… “?

    What is the issue?




    Sorry, I meant: “let me know”.

    As i told you before, everything worked fine untill the plugin suddenly stopped working and it doesn’t send any email anymore or the sending is very, very slow (2% in more than 12 hours).

    I’m using the same plugin on other website with the same amount of subscribers (around 6000) and it works perfectly even with the WP CRON and it completes the process in a couple of days.

    I was thinking that maybe some other plugin’s upgrade make some kind of conflict with kNews? Is that possibile?

    What are the “compatibility options”?



    I found out why it does not work!!!!
    But i need help…

    So i’m using the same plugin on 3 different website. They’re all on the same host provided by ARUBA and they all have the same configuration with the proper SMTP settings naturally.

    In 2 of them, this plugin works just perfectly. In one of them ( if i select “SEND EMAIL BY SMTP” it stops working, the delivery gets really slowly and the delivery returns a lot of errors.

    If i select “SEND BY WORDPRESS” it works just fine.

    The thing is that i always used SMTP then it stopped working and i realised why just now after months!?

    If i run a test it work fine and i receive the test-email.

    Please, tell me how i can solve this.
    Thank You

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘sending terribly slow’ is closed to new replies.