Support » Plugin: Ultimate Member - User Profile & Membership Plugin » Sending review of the administration e-mails activation accounts

  • Resolved Natalia

    (@nataliacg)


    ¡Hello! 😀

    I have created a user profile called “Reader”, which applies to everyone who registers on the web.

    When the “Require e-mail activation” option is selected in the “Reader” user profile, the system automatically sends him an e-mail in which the link appears to enter his profile. So far everything is right.

    But I would like to do something else: I want that once readers fill out the registration form, they will receive an email that says that the administration is reviewing their application and that if it is approved they will receive an email with a link to activate their account.

    I need to be able to review every request that comes to me, instead of being automatically authorized by the system.

    I suppose that in the user profile “Reader” I have to check the option “Require the review of the administration”, but then I go to Settings> E-mails and I don’t know what emails I have to activate and which ones to deactivate for these operations to be carried out.

    Can you help me? Thank you very much!

    Natalia

Viewing 4 replies - 1 through 4 (of 4 total)
  • Hiya! Please, I have to do an update:

    I have activated:

    Welcome email
    Account activation email
    Pending review email
    Account approved email

    When the user completes the registration form, the following happens:

    -When the user has submitted the registration form, on the screen appears a message that I have configured before: “Thank you for your request, we will contact you if it is approved”. OK, right.

    -Then, the reader receives an email from “We are valuing your request”… or not. Sometimes it comes and sometimes it doesn’t.

    -Then, “UM Action: Forward the activation email” and then the reader does not receive any email… and sometimes an “Account activation email” email arrives.

    -Then, “Action UM: Approve the registration”, and the reader receives “Welcome email”, but sometimes not.

    -Sometimes, the reader ONLY receive “Account approved email”.

    -Finally, sometimes you don’t even get any email.

    Conclusion: I don’t know what actions I have to take to get the reader to:

    -FIRST, an email that says that the administration is reviewing their application and that if it is approved they will receive an email with a link to activate their account.

    -THEN, an email that says your application has been approved and you can now activate your account.

    I need these two steps to be taken, this way and always. Right now it happens sometimes yes and sometimes no, or nothing happens at all.

    I am unable to set any guidelines here and I have tried everything. At this point I think the system has a life of its own and does what it wants.

    Please, What is happening? What I have to do?

    Thank you very much.

    Plugin Contributor Champ Camba

    (@champsupertramp)

    Hi @nataliacg

    I suggest that you install an SMTP plugin and then set up the SMTP credentials to fix the issue with the email relay.

    https://wordpress.org/plugins/wp-mail-smtp/

    Let us know if this works for you.

    Regards,

    Oh, yes, it works, OMG, OMG, thank you!!

    Plugin Contributor Champ Camba

    (@champsupertramp)

    Hi @nataliacg

    Thanks for letting us know. I am closing this thread now.

    Regards,

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.