Support » Plugin: OneSignal - Web Push Notifications » Sending out push before Scheduled Post

  • At first, I thought I was crazy (well, maybe I am), but today, April 6.2019 I was putting in a scheduled post for May 10, 2019, and the darned thing sent out a notification. The post is in draft mode, not published. This is version Version: 1.17.0 of One Signal and version Version 5.1.1 of WordPress. The plugin worked flawlessly before this, and then it just started doing today.

    One thing I did notice. The post did not have a title before WP did an auto-refresh so the post still had the id number for the permalink instead of the regular permalink mm/post-title. When I hit the schedule button, the permalink did change, but the push notification when out with the post id number instead.

    What is irksome about this particular post is that I do not have a featured image for it yet since I have not actually made the food yet (it’s a recipe blog). I wanted it in my list of posts for May ready to go and just add the picture when I make the dish in April. Now, I’m kind of scared to write posts to be scheduled.

    The page I need help with: [log in to see the link]

Viewing 1 replies (of 1 total)
  • Plugin Author OneSignal


    This is the first we’re hearing of this problem but will definitely look into it further. Thank you for bringing it up. In the meantime, we recommend configuring the plugin to not automatically send a push notification (doesn’t automatically check the box). Then, you can go back to the particular post and hit update with the checkbox checked in order to send the notification manually. This will be a temporary inconvenience while we investigate where the issue is. We would be able to better assist you if you reach out directly through our support channel at

    The OneSignal Team

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.