Support » Plugin: Contact Form 7 » Sending message to my email – not working

  • Resolved rejvar

    (@rejvar)


    Hello,

    The contact form I had set up on my careers page, no longer works. It stopped working when I updated the plugin and the last email I received from the form was January 15, 2019. I receive an error “There was an error trying to send you message. Please try again later.”

    The adjustments I have done to try to fix the issue is as follows:

    1. Tested WP SMTP plugin by changing SSL to TLS, deactivating SMTP plugin then reactivating after clearing cookies, tested plug-in and test emails work via SMTP
    2. Deactivated CF7 then reactivated – nothing
    3. Deleted CF7 from FTP then reinstalled plugin – nothing
    4. Tested other contact form plug ins such as Lite WP Forms and I am able to receive emails(but I love CF7 and want to make it work)
    5. Re-created a new contact form in the CF7 plugin – nothing
    6. Re-issued new password for WordPress access (SMTP) application via G-Mail account and got it all working, test email came through but when I tried CF7 it still doesn’t send emails.
    7. Changed SMTP plug-in from WP SMTP to Easy WP SMTP and test emails from E-SMTP works

    I am not sure if I did everything I can so any other suggestion than fixing SMTP or deactivating plugin would be very helpful. Is there something in the update that may not work with the latest version of WP? Thank you!!

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Same problem here.

    I receive an error “There was an error trying to send you message. Please try again later.”

    Is this message in an orange or red border?

    @weberteam – see I have the same problem! Can I just reply to someone else’s post with “Me too”?.

    If you are willing to create a new question, which details your issues, somebody will likely be able to help you there.

    @buzztone I see an orange border around the error sign.

    CF7 5.1.+ updated to reCAPTCHA (v3).

    Are you using reCAPTCHA on your site?

    I was using recaptcha let me try that. It stopped working and I had made adjustments. I’ll keep you posted. Thank you!

    The orange border indicates reCAPTCHA v3 is not working correctly on your site.

    See Contact Form 7 5.1.1 – theme needs to properly loads JavaScript in the footer area of each page.

    Switch temporarily (nothing will be lost when you switch back) to a WP default theme to see if the problem goes away.

    If this fixes the problem & you can’t get your theme fixed, you might try using Contact Form 7 – reCaptcha v2 in addition to Contact Form 7. Once installed and configured it offers the same reCaptcha functionality you are used to in previous versions of Contact Form 7 (recommended by CF7 plugin author).

    Hello my friend, go to your hosting of your email and check your email account if the email box is full.

    If your email box is full, you may not be able to receive any more email, even if everything is working.

    There is a limit to receiving emails in many lodgings.

    If your problem is not this, I recommend you install the Postman SMTP plugin and configure it according to your email account that is in the hosting of your site.

    Also remember that the default e-mail sending / receiving (smtp) port is 587 in many hosts.

    Perfect. Thank you @willianxz and @buzztone. I have time this morning to take these ideas and get it going. Keep you posted with the steps I took for reference in case someone else had the problem.

    Hello again! I got it back up. Thank you for your help here.
    Email box was not full so that seemed good to go since I was still receiving emails from other outlets.
    Then as for reCAPTCHA, I was having issues with reCAPTCHA v2 having tried what was mentioned. In the midst of fumbling through more forums I found a way to rollback my CF7 to see if that worked. It did not, however, when I re-updated the the plugin, my form started working. I didn’t have to try to see if JavaScript had issues. I read that reCAPTCHA v3 works in the background (this is why I love CF7) and that is why we don’t see it on our front and back end. Thank you again for all your advise.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Sending message to my email – not working’ is closed to new replies.