Support » Plugin: Payment Plugins for Stripe WooCommerce » Sending invoice mails

  • Resolved umutusu

    (@umutusu)


    Hi!
    I hope you are doing well!

    I’m testing the plugin and e-mails sent by the plugin and/or stripe itself right now.

    Is there a way to auto send invoice e-mails, instead of doing manually in the edit order page, choose action, email invoice/order details to the customer?

    In woocommerce -> settings -> emails, “Email Receipt If enabled, an email receipt will be sent to the customer by Stripe when the order is processed.” is checked.

    In stripe -> settings-> emails, “Email customers about… successful payments” is ON.

    But there is no invoice mail sent.

    I disabled other webhook from stripe gateway for woocommerce plugin on stripe webhooks page.
    Should I maybe delete it totally? (I don’t use that plugin anymore).
    Or it is maybe I’m in test mode?
    Thank you for your help.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Payment Plugins

    (@mrclayton)

    Hi @umutusu,

    It sounds like you don’t have an email plugin installed. Makes sure you have something like Sendgrid enabled that allows you to send emails from your WordPress site.

    The other Stripe plugin’s webhook wouldn’t be preventing email from sending. But since you’re not using that plugin anymore I recommend you remove that webhook entirely.

    Kind Regards,

    Thread Starter umutusu

    (@umutusu)

    Hi @mrclayton,
    I’m using Post SMTP plugin to send emails through gmail (gmail with my domain).
    I have also mailpoet installed butsetup to send with gmail.
    By the way all other mails (order received, order processing) are going out automatically without any problem.
    I’m going to re-setup the smtp plugin to see if it changes anything.

    Thread Starter umutusu

    (@umutusu)

    I did the re-setup and it didn’t change anything.
    I deactivated the Post SMTP plugin and tried to just use mailpoet (so now it’s mailpoet is sending transactional emails, not Gmail)
    But it still the same.
    When I receive the order, the first email “your order is received/processing) email is going out automatically to the client. At the same time, the website admin also receives the “there’s a new order” email automatically.
    So, because those 2 emails going out automatically, I don’t think there is a problem with WordPress sending emails.
    Then in the backend, I confirm the order by changing its status to “completed” (because in stripe it’s set up with default status. So all orders are in “processing” status by default), and the second email to the client, “your order is completed” goes out.
    I think that at that moment, invoice email also should go out automatically, but it never does (until I send it myself on the edit order page by choosing the action, “email invoice/order details to the customer” and click update.
    As I said, I don’t think there’s a problem with WordPress sending emails.
    What do you think causes this?

    Plugin Author Payment Plugins

    (@mrclayton)

    @umutusu I am not sure I understand the issue. Are you saying the Stripe automated email is not being sent when you expect it to?

    The Stripe plugin has no control over the WooCommerce generated emails. All that logic is part of WC.

    The Stripe invoice email is sent by Stripe using the email address entered in the billing fields of the checkout page. It’s sent to the customer, not the admin.

    Thread Starter umutusu

    (@umutusu)

    Well,
    because I’m testing, I’m the admin and also I’m the client (in a private browser with another email), to be able to check if everything is working or not. And I’m aware that the stripe plugin has no control over woocommerce generated emails.
    And yes, what I’m saying is the stripe automated invoice email is not being sent.
    Since all the other automated emails are working (eg. “we received your order” email which the customer receives and “you received an order” email which the site admin receives) as I expect them to work, but not the stripe automated email; I thought to ask you first, thinking its a webhook problem.

    Plugin Author Payment Plugins

    (@mrclayton)

    Hi @umutusu,

    I now understand your question. Receipts from Stripe are not sent automatically in test mode.

    https://stripe.com/docs/receipts#receipts-in-test-mode

    Once you enable live mode you should receive the automatic email from Stripe.

    Kind Regards,

    Thread Starter umutusu

    (@umutusu)

    Thank you for clearing that up.
    I was thinking that there’s a problem with the terms invoice and receipt 🙂 and it’s always confusing.
    So what about the invoice from woocommerce. Should I send that manually every time? Or should I even send it?
    By the way, in the stripe dashboard-payments, when I click one of the payments to see events and logs, there are errors of Payment webhook response:
    -A webhook that is subscribed to the event hasn’t successfully responded yet: charge.succeeded
    -A webhook that is subscribed to the event hasn’t successfully responded yet: payment_intent.succeeded
    Both of them in their log details, webhook attempts failed (twice) for:
    https://www.mielagility.com/wp-json/wc-stripe/v1/webhook

    Plugin Author Payment Plugins

    (@mrclayton)

    @umutusu,

    Make sure you followed the plugin’s documentation on setting up the webhook. You have to copy and paste the webhook secret into the plugin settings.

    Regarding the customer invoice email, my understanding is that’s a manual email only. But you can consult the WooCommerce docs to be sure.

    Thread Starter umutusu

    (@umutusu)

    I’m going to test automated receipts once I go “live” but apart from that everything is working fine now.
    The problem with the webhook was caused by CMP coming soon plugin. one I deactivated it, webhook connection failed reports are gone.
    Thank you for your quick help.
    Very much appreciated

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Sending invoice mails’ is closed to new replies.