WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Sending emails not working

[Resolved] Sending emails not working

Viewing 15 replies - 1 through 15 (of 16 total)
  • l3l2ad
    Participant

    @l3l2ad

    What other plugins do you have installed on your site? Where is your site hosted?

    I have a good few other apps but I seemed to have narrowed it down to my email servers but have not resolved the issue.
    I can send mails using Contact Form to my hotmail address but the mail settings for my site have been forwarded to Google and I am using Google Apps to host my email. It’s any address on that domain that I have a problem. They don’t even appear in my spam folder.
    Any ideas? Thanks for coming back to me on this it’s been hard to try find an answer.

    l3l2ad
    Participant

    @l3l2ad

    Give us a link to visit – I’m not familiar with Google Apps hosting, but there might be a way. Can you let us know the version of WP that you’re using and any other plugins that you have? I don’t want to suggest or recommend ones that you already have.

    I ran across this one when I was looking for another issue.

    WP Mail SMTP
    http://www.callum-macdonald.com/code/wp-mail-smtp/
    and http://wordpress.org/extend/plugins/wp-mail-smtp/

    Google Apps is here – http://www.google.com/enterprise/apps/business/
    And these are the settings I only needed to change to make the mail work with Google Apps, I just change the MX Records – http://support.google.com/a/bin/answer.py?hl=en&answer=174125

    Here is all the plugins I have installed – http://imageshack.us/photo/my-images/843/pluginsscreenshot.png/

    l3l2ad
    Participant

    @l3l2ad

    Install WP Mail SMTP – that should fix your issue. CF 7 uses wp_mail() to send so it may still be trying to use WP for sending instead of GMail.

    Found another thread here that points to adjusting the MX records ||
    [Plugin: Contact Form 7] submission successful but no email

    Can you tell me how to identify errors in Contact Form 7 updated this morning to 7.3.3.3?

    I have a simple Request Form on http://www.ncfcc.us/rfc.

    It has been working fine – now all the sudden folks trying to use it are getting the following error.

    Failed to send your message. Please try later or contact the administrator by another method.

    Anxiously awaiting your reply. This is my first ever request for help with WordPress plugin so I hope I am doing it correctly!

    Thanks so very much in advance for your help!

    I figured out my problem. In the “Mail to:” I had a “;” after each name and not a “,”. After changing the semicolon to a comma it is working fine.

    Thanks very much for the link to the other post, I didn’t see that topic at all when looking for a solution.
    The problem seems to be with the cPanel MX settings for the Email Routing. It was set to Local Mail Exchanger which means it got lost when it hit the local server. I have since changed it to use Automatically Detect Settings which looks at my MX records and forwards to Google App mail servers straight away.
    I have tested it and it seems to be working. I’ll monitor it and report back if it goes again.
    Thanks l3l2ad

    l3l2ad
    Participant

    @l3l2ad

    Glad I could help!

    Thanks ! WP Mail SMTP worked for me as well.

    btw, if it’s possbile to elaborate on how to change those MX Records settings on dreamhost, it will be nice, i didn’t find an answer for this anywhere.. 🙂

    l3l2ad
    Participant

    @l3l2ad

    @erantdo – Google is your friend and most dangerous tool on the net.

    Googled this “change mx records dreamhost” – no quotes

    Found a possible solution here – http://wiki.dreamhost.com/MX_record

    Guys, I would sincerely appreciate your help. I am not an expert at these things, but here is the situation:
    Contact form “appears” to be working by saying “Your message has been sent”, but I never receive the messages. I use GoDaddy for hosting. Could you please point me in the right direction? Thank you!

    You should try contacting GoDaddy’s support team.
    For me, before I switched my smtp settings to the Google Apss setting, the plugin used my host’s (Dreamhost) smtp server. When I contacted the Dreamhost support team, it turned out they changed their policy, so some messages didn’t go through, and they refered me to a directory in the FTP server that stored those emails.
    However, this won’t resolve your problem – I think you’ll need to consult with the GoDaddy’s support team to see what can be done.

    l3l2ad
    Participant

    @l3l2ad

    @starkos1 – I have GoDaddy as well. How do you have the plugin configured to send – are you using just Mail 1 or both? You should be able to use the address you want it to send to in the options page. I was able to set it up and use it without making any changes.

    Hey I’ve got a problem with my GoDaddy contact form, a bit different then people before posted.
    My webformailer is working when pressing submit, i’m receiving emails and everything, problem is its not redirecting, but code looks fine, maybe anyone knows where could be a problem?

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘[Resolved] Sending emails not working’ is closed to new replies.