Support » Plugin: Contact Form 7 » Google reCAPTCHA causing send error

  • davidkonicek

    (@davidkonicek)


    Contact Form 7 forms will not submit. The error message I set for “Sender’s message failed to send” with the red border appears after attempting to submit any form. I don’t know if the problem has to do with a recent COntact Form 7 plugin update, or just Google reCAPTCHA. I have Google reCAPTCHA V3 integrated. However, I just disabled it, and the form submissions have started working. When the reCAPTCHA was active, Chrome on desktop was working fine, but Chrome on iPhone (normal and incognito), Microsoft Edge on desktop, Safari on desktop and iPhone, and Internet Explorer were showing the error message after clicking submit on any form. I’m using the Conditional Fields plugin, but the error was showing up on all forms, even when not using Conditional Fields. I’m using WP Rocket for caching, and I have cleared the cache, preload cache, and critical path CSS. This is recently the third website that I have had to disable Google reCAPTCHA because it is breaking the functionality of my websites. Let me know if there is some workaround, so I’m not bombarded by spam after disabling Google reCAPTCHA.

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Takayuki Miyoshi

    (@takayukister)

    What other plugins and theme do you use on the site?

    Thread Starter davidkonicek

    (@davidkonicek)

    Genesis theme, and Avada on a different website that had the same problem.

    Plugins:
    AddToAny Share Buttons,
    Admin Menu Tree Page View,
    BE Subpages Widget,
    Beaver Builder Plugin (Pro Version),
    Better WordPress Google XML Sitemaps,
    Conditional Fields for Contact Form 7,
    Contact Form 7,
    Contact Form CFDB7,
    Content Aware Sidebars,
    Display Posts,
    Easy Social Feed,
    Extra Product Options (Product Addons) for WooCommerce,
    Falling Menu Fix,
    Image Optimization service by Optimole,
    Insert Headers and Footers,
    Invisible Captcha,
    Jetpack,
    Lessify WordPress,
    ManageWP – Worker,
    MetaSlider,
    Minimum Password Strength,
    MonsterInsights – Forms Tracking Addon,
    MonsterInsights Pro,
    PayPal for WooCommerce,
    Perfect Images (Retina, Thumbnails, Replace),
    PowerPack for Beaver Builder,
    Really Simple CAPTCHA,
    Really Simple SSL,
    Regenerate Thumbnails,
    Rename wp-login.php,
    Search & Replace,
    SEO Ultimate,
    Simple History,
    Simple Image Sizes,
    Sitemap,
    Smush,
    String Locator,
    Sucuri Security – Auditing, Malware Scanner and Hardening,
    WooCommerce,
    WooCommerce Name Your Price,
    WordPress Importer,
    WP Google Maps,
    WP Image Size Limit,
    WP Rocket,
    WP Simple Galleries.

    I’m developing a new website for them that won’t have so much clutter.

    Perhaps more importantly, here are the plugins that are active on all three websites with this issue:
    Contact Form 7,
    Image optimization service by Optimole,
    ManageWP – Worker,
    WP Rocket.

    Plugin Author Takayuki Miyoshi

    (@takayukister)

    Try switching to the default theme, deactivating all plugins excluding Contact Form 7, Really Simple CAPTCHA and WordPress Importer, and clearing all cache data.

    Why you are advised to deactivate plugins and switch to the default theme.

    @davidkonicek

    There is a known issue with CF7 and caching plugins. WP Rocket documented about it here:

    https://docs.wp-rocket.me/article/1495-contact-form-7-is-not-working

    • This reply was modified 3 months, 4 weeks ago by JBennett360.
    • This reply was modified 3 months, 4 weeks ago by JBennett360.
    Thread Starter davidkonicek

    (@davidkonicek)

    The WP Rocket resolution didn’t help me. Does anyone have any insight on this? I’ve seen other people having similar problems since a Contact Form 7 update a couple months ago. I just tried version 2 and 3 of reCaptcha, and the checkbox doesn’t appear on my site for version 2, and version 3 just gives me the error message when clicking Submit on the form. Several of my websites have this problem, seemingly regardless of the theme or other plugins I’m using.

    Thread Starter davidkonicek

    (@davidkonicek)

    @takayukister Have you found out anything more regarding this issue? I’ve seen a few other people post about it, but none of them with a fix yet.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.