WordPress.org

Support

Support » Plugins and Hacks » Send with no captcha in text field not validating ? little arrow keeps spinning.

Send with no captcha in text field not validating ? little arrow keeps spinning.

  • Send with no captcha in text field not validating? little arrow keeps spinning. I am using Contact Form 7 with Really Simple CAPTCHA on WP 3.5.2 all the (required) fields will validate when i take the captcha out but when i add it back in and submit the form with nothing in it the text filed for the captch the little arrow keeps spinning. also when the form is all filed out right and you send it, the form dose not replay back that the form was sent with the nice green box or clear the form this only happens when the captcha in in the page. It is not validating the form?
    Any help would be great thank you for your time.

    page i am working on

    http://wordpress.org/extend/plugins/really-simple-captcha/

Viewing 10 replies - 1 through 10 (of 10 total)
  • Check if the numbers in [captchac captcha-739] and [captchar captcha-739] are the same.

    yes are the same: EG

    <p>[captchac captcha-316]
    Type Captcha in here
    [captchar captcha-316]</p>

    <p>Name (required)
    [text* your-name] </p>

    <p>Email (required)
    [email* your-email] </p>

    <p>City (required)
    [text* City /25] </p>

    <p>Subject
    [text your-subject] </p>

    <p>Your Message
    [textarea your-message] </p>

    <p>Send us a pic of the repair JPG image only (Not Required)
    [file FileUpldose]</p>

    <p>[captchac captcha-316]
    Type Captcha in here
    [captchar captcha-316]</p>

    <p>[submit “Send”]</p>

    Well, I had that problem with my contact form and captcha. I can’t help you in another way. I hope someone else will find a solution for your problem.

    Thanks for your comment i think is has to do with a wp update but i dont know as of now i am just using the quiz to help keep spam down. I would like to find a fix for this. I am glad i am not the only one who is having this prob. what version of wp are you runing? I am running WP 3.5.2

    are you not using the captcha anymore or what did you do to salve it.

    Hi, I’m using WP 3.5.2 and I solved my problem as I explained above, because the mail was sent even with no captcha writen in captcha field. Then I saw that the numbers for captchac and captchar were different I wrote them equal and contact form demands captcha to be written in the requred field. Sorry I can’t help you.

    Thank you for your time to try and help 🙂

    michael@hoolahan.net

    @michaelhoolahannet

    hi,

    if you are still having problem…

    upon submitting form, contactform7 is posting to the server using ajax. best install fiddler to see what error is coming back from the server during this post.

    For me, it was dying trying to delete old images…see below.

    HTTP/1.1 200 OK
    Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
    Pragma: no-cache
    Content-Type: application/json; charset=UTF-8
    Expires: Thu, 19 Nov 1981 08:52:00 GMT
    Server: Microsoft-IIS/7.5
    X-Powered-By: PHP/5.4.14
    Set-Cookie: woocommerce_items_in_cart=1; path=/
    X-Powered-By: ASP.NET
    Date: Fri, 06 Sep 2013 11:08:06 GMT
    Content-Length: 801
    <b>Warning</b>:  unlink(C:\inetpub\XYZ/wp-content/uploads/wpcf7_captcha/1315603517.png): Permission denied in <b>C:\inetpub\XYZ\wp-content\plugins\really-simple-captcha\really-simple-captcha.php</b> on line <b>219</b>
    
    <b>Warning</b>:  unlink(C:\inetpub\XYZ/wp-content/uploads/wpcf7_captcha/1315603517.txt): Permission denied in <b>C:\inetpub\XYZ\wp-content\plugins\really-simple-captcha\really-simple-captcha.php</b> on line <b>219</b>
    {"mailSent":true,"into":"#wpcf7-f18-p23-o1","captcha":{"captcha-789":"http:\/\/XYZ:6496\/wp-content\/uploads\/wpcf7_captcha\/420346992.png"},"message":"Your message was sent successfully.

    Thanks.”}

    Horizont

    @horizont

    Apparently this has to do with a permission matter.
    I followed the solution provided here:

    http://wordpress.org/support/topic/plugin-really-simple-captcha-submit-appears-to-be-timing-out-but-its-really-working?replies=23#post-3520303

    and now it works for me, i only hope it doesn’t brake security in any way but I couldn’t find any other solution.

    Hope this helps

    EDIT: I actually had the same server response as michael, changing the permission from 0444 and 0440 to 0777 and 0770 solves the problem (because permissions change from read only to rw)

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Send with no captcha in text field not validating ? little arrow keeps spinning.’ is closed to new replies.